locked
.NET 3.5 install fail; 1603 RRS feed

  • Question

  • I have had a devil of a time trying to get VS2008 Team Architect installed on a Vista Ultimate box.  I had VS2008/SQL Server 2008 Express installed, but removed all of that, and used the .NET cleanup tool to get rid of the existing .NET framework packages.  However, there are still remnants of the .NET 4.0 CTP that I had installed previously (and though removed...) as well as the F# CTP:

    • "F# Compiler and F# for Visual Studio 2008, Version 1.9.6.16"
    • "Microsoft .NET Framework 4 Client Profile Beta 1"
    • "Microsoft .NET Framework 4 Extended Beta 1"
    When I try to install VS2008, the setup process fails and the following is the content of the log:

    [06/17/09,15:05:46] Microsoft .NET Framework v3.5: [2] Error code 1602 for this component means "User cancelled installation.
    "
    [06/17/09,15:05:46] Microsoft .NET Framework v3.5: [2] Setup Failed on component Microsoft .NET Framework v3.5
    [06/17/09,15:05:47] VS70pgui: [2] DepCheck indicates Microsoft .NET Framework v3.5 is not installed.
    [06/17/09,15:05:47] VS70pgui: [2] DepCheck indicates Microsoft Document Explorer 2008 was not attempted to be installed.
    [06/17/09,15:05:47] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio Web Authoring Component was not attempted to be installed.
    [06/17/09,15:05:48] VS70pgui: [2] DepCheck indicates Microsoft Visual Studio Team System 2008 Architecture Edition - ENU was not attempted to be installed.
    [06/17/09,15:05:48] VS70pgui: [2] DepCheck indicates Microsoft .NET Compact Framework 2.0 SP2 was not attempted to be installed.
    [06/17/09,15:05:48] VS70pgui: [2] DepCheck indicates Microsoft .NET Compact Framework 3.5 was not attempted to be installed.
    [06/17/09,15:05:48] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 was not attempted to be installed.
    [06/17/09,15:05:48] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 Design Tools was not attempted to be installed.
    [06/17/09,15:05:48] VS70pgui: [2] DepCheck indicates Microsoft SQL Server Compact 3.5 For Devices was not attempted to be installed.
    [06/17/09,15:05:48] VS70pgui: [2] DepCheck indicates Microsoft Device Emulator version 3.0 was not attempted to be installed.
    [06/17/09,15:05:49] VS70pgui: [2] DepCheck indicates Microsoft SQL Server 2005 Express Edition (x86) was not attempted to be installed.
    [06/17/09,15:05:49] VS70pgui: [2] DepCheck indicates Microsoft Windows SDK for Visual Studio 2008 Tools (x86) was not attempted to be installed.
    [06/17/09,15:05:49] VS70pgui: [2] DepCheck indicates Microsoft Windows SDK for Visual Studio 2008 Headers and Libraries (x86) was not attempted to be installed.
    [06/17/09,15:05:49] VS70pgui: [2] DepCheck indicates Microsoft Windows SDK for Visual Studio 2008 Win32 Tools (x86) was not attempted to be installed.
    [06/17/09,15:05:49] VS70pgui: [2] DepCheck indicates Microsoft Windows SDK for Visual Studio 2008 .NET Framework Tools (x86) was not attempted to be installed.
    [06/17/09,15:05:49] VS70pgui: [2] DepCheck indicates Microsoft Windows SDK for Visual Studio 2008 SDK Reference Assemblies and IntelliSense (x86) was not attempted to be installed.
    [06/17/09,15:05:49] VS70pgui: [2] DepCheck indicates Crystal Reports Basic for Visual Studio 2008 was not attempted to be installed.
    [06/17/09,15:05:50] VS70pgui: [2] DepCheck indicates Microsoft SQL Publishing Wizard was not attempted to be installed.
    [06/17/09,15:10:19] Microsoft .NET Framework v3.5: [2] Error code 1603 for this component means "Fatal error during installation.
    
    I see that the first error line says "1602", and "user cancelled" installation, but I am quite sure that I did not.  I started the install and left it unattended for a 2-3 minutes.  Further down it reports a 1603 fatal error, but no further details.

    After reading other posts here, as well as a few blogs, I've tried ensuring that IIS is started, removing/reinstalling IIS.  I've tried installing .NET 3.5 from the full setup, to this result:

    [06/17/09,14:38:35] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [06/17/09,14:38:50] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    [06/17/09,15:10:09] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [06/17/09,15:15:11] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [06/17/09,15:25:19] Microsoft .NET Framework 3.5 'package': [2] Error: Installation failed for component Microsoft .NET Framework 3.5 'package'. MSI returned error code 1603
    [06/17/09,15:25:32] WapUI: [2] DepCheck indicates Microsoft .NET Framework 3.5 'package' is not installed.
    

    I'm at my wit's end, and reinstalling Vista is a piss-poor option.  Any suggestions?


    ben
    Wednesday, June 17, 2009 8:27 PM

All replies

  • Hi,

    Could you help collect the complete setup logs so I can take a look?

    1. First clean up everything in your %temp% folder, including any existing log files.
    2. Install .NET Framework 3.5 SP1
    3. If fails, use the log collection utility to packup the log files. You can also post the feedback to the Connect site.
    4. Upload the log to the SkyDrive and paste the link here.

    Thanks,

    Jie
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Send us any feedback you have about the help from MSFT at fbmsdn@microsoft.com.

    The CodeFx Project
    My Blog (in Simplified Chinese)
    Thursday, June 18, 2009 6:29 AM