locked
SharePoint Designer 2010 encountered an error generating the task form. RRS feed

  • Question

  • I'm working with SharePoint Designer 2010. I have been able to publish workflows on and off while developing two workflows. I have been getting intermittently the following error:

    SharePoint Designer encountered an error generating the task form.   Server was unable to process request --> Activation could not be completed because InfoPath Form Services support feature is not present. 

    Originally when I got this problem, I was told by another SharePoint person to delete the workflow initiation form and that it would be created upon publishing the workflow.   She was able to publish but as soon as I did it, I couldn't.   Another time I was told to open up the initiation form because it had "Needs update" next to the title of the initiation form.   Then save the initiation form anywhere and then the workflow would work.   That worked for the other person (farm admin) but it didn't work for me. 

    In talking to another SharePoint person, I was told to never delete the initiation form because SharePoint needs the form and I agree because when I open that form it has the "Start" button and  I believe the "Cancel" button.  

    Because I was getting the error again, I was told to recreate my workflow from scratch.   After I did that, I tried to publish and I couldn't-I got the same error.   I tried recreating a brand new workflow based on a new list and that didn't work. 

    Today, I found an article that suggested to clear the SharePoint Designer caches.   I did that and still was not able to publish.

    I decided to create a list workflow based on another list and this time the workflow was saved.   However, I was not able to publish it - I got the same error.  So I'm not sure what else to do.  Anyone run into this problem before? 

    Friday, February 16, 2018 7:32 PM