none
how to explicitly tell application to use a certain framework version RRS feed

  • Question

  • Hello All,

    How can one explicitly tell your application to use a certain framework version?

    I have a couple of versions installed and need to test compatibility with 4.0 specifically. I do not want to uninstall the other versions.

    Please help.

    Harriet

     

    Thursday, May 5, 2011 12:01 PM

Answers

  • Hi,
      In visual studio, you have the option to select the target application version. There you can mention that, which is the least version your application can run. And from v 2.0 onwards, the change in the assemblies are minimal and new dll's are added. For v 4.0, there is two GAC and it will handle it its on way to make sure that the proper dlls are loaded for the application. CLR version 2.0 is used for .Framework 2.0 and 3.5 and CLR VErsion 4.0 is used for application targeting .NET v 4.0.


    -- Thanks Ajith R [MCTS:ASP.NET&Win Forms]
    Thursday, May 5, 2011 1:09 PM