locked
Click once shortcut not launching application in Windows 8 RRS feed

  • Question

  • Created a click once application and published it to local host. Installed the application using the  publish page, the application got launched for the first time. Now, closed the application and tried to open it from the shortcut. I was able to see a small window briefly saying "Verifying application requirements. This may take a few moments." but nothing happened after that. I have created click once applications in windows 7 and had not faced any issues like this before. Is this a known issue with windows 8? Do we have any resolution? I would greatly appreciate any suggestions to overcome this issue.
    Tuesday, July 30, 2013 4:51 PM

All replies

  • Just make sure in the application manifest (or visual studio properties on your project) that the application is at the install location your set, and also what is the URL for updates and that it is correct and accessible.

    I have this working without a problem.

    Although, my click once application is digitally signed. Windows 8 was a bit un happy when I tried to run it before it was signed.


    Regards, Shai Petel.

    Tuesday, July 30, 2013 5:47 PM
  • You need to digitally sign the main .exe file with a digital certificate, that is new in windows 8, otherwise windows 8 won't trust the main application to run.

    We're not talking about signing manifests, we are talking about signing the main .exe file the application runs with.


    ----------------------------------------------- "Cannot find reality.sys ... Universe Halted!"

    Tuesday, July 30, 2013 5:54 PM
  • Shai,

    Thanks for the immediate reply. I am not able to post the url in the forum as I get a message "Cannot post link or image until the account is verified" during my submit. My publishing folder location is internal url and it is the same for installation url and update location. So, I did not had to mention them again for installation url and update location in properties. I verified my Virtual directory and it  has the application exe. I looked at my manifest and I am not able to find the publishing folder url,  Can you please tell me the xml tag I need to look for in the manifest file. I am yet to try it with digitally signed.

    Tuesday, July 30, 2013 6:33 PM