Bug in SharePoint Designer 2013 workflows RRS feed

  • Question

  • I have a problem with SharePoint Designer 2013 working on Office 365 which has caused me to redo my workflow twice already! Basically, I create the workflow and work happily by testing and deploying. However, as soon as I close SharePoint Designer and go back to the workflow to edit it, I get a error. "Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature.".

    I have uninstalled SPD 2013, Re installed it, Tried the hot fix, tried the Service Pack 1 all to no avail!

    Once I click OK on the error, I get another message stating "SharePoint Designer cannot display the item."

    I have also cleared the cache by following steps in this article:


    I'm running SharePoint Designer 2013 on Windows 8.1 I've tried the 32 bit and 64 bit versions of SPD 2013.

    None of these fixed my issue. Anyone having the same problem with SPD and Office 365?

    Wednesday, April 30, 2014 8:10 AM


All replies

  • Hi,

    According to your post, my understanding is that you failed to edit SharePoint Designer 2013 workflows.

    I recommend to install the hotfix:



    If the issues still exists, you can go to Account > Switch Account and type in the credentials of the site you are trying to open.

    Here is a similar thread for your reference:


    Best Regards,

    Linda Li

    Linda Li
    TechNet Community Support

    • Marked as answer by JasonGuo Tuesday, May 6, 2014 2:32 PM
    Thursday, May 1, 2014 3:15 AM
  • This happens either because of corrupt activity in the workflow or cache is not cleared. Try to take frequent backups using save as template and if you can open it in other environments like QA then try to copy stage actions from there and if workflow is small just recreate it. In our case we fixed it by clearing cache, installing 2 fixes mentioned by Linda.

    MCTS Sharepoint 2010, MCAD dotnet, MCPDEA, SharePoint Lead

    • Proposed as answer by Marco A Geronimo Tuesday, May 19, 2015 4:53 PM
    • Unproposed as answer by Marco A Geronimo Tuesday, May 19, 2015 4:53 PM
    • Proposed as answer by Sachchin Wednesday, May 20, 2015 5:06 AM
    Tuesday, May 20, 2014 11:02 AM
  • Execute the following steps:

    1- Install the Service Pack 1:
       - Microsoft SharePoint Designer 2013 SP1 (x86)
         - http://www.microsoft.com/downloads/details.aspx?FamilyId=02be1bb4-5bda-41c6-899a-fdfccc59992d

       - Microsoft SharePoint Designer 2013 SP1 (x64)
         - http://www.microsoft.com/downloads/details.aspx?FamilyId=b057a5fa-eeac-4537-b8b4-e3050a72da7c

    2- Install the following fixes:
       - kb2727100 (http://support.microsoft.com/kb/2727100)
       - kb2837667 (http://support.microsoft.com/kb/2837667)

    3- Install the Visual Studio 2005 extensions for .NET Framework 3.0 (Windows Workflow Foundation)
       - http://www.microsoft.com/en-us/download/details.aspx?id=23072

    4- Run prompt command:
         rmdir "%LOCALAPPDATA%\Microsoft\WebsiteCache\" /s /q
         rmdir "%APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache\" /s /q
         rmdir "%APPDATA%\Microsoft\Web Server Extensions\Cache\" /s /q

    5- Re-Register the workflow for site collection
       - Register-SPWorkflowService -SPSite "https://myhost/mysite" -WorkflowHostUri "https://workflowhost" -AllowOAuthHttp -Force
           - Referência https://technet.microsoft.com/pt-br/library/jj663115.aspx


    Marco Aurélio Gerônimo

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com .


    Tuesday, May 19, 2015 4:53 PM
  • I too had this problem.  It began with a fresh install of x86 32bit install of SPD with SP1 on a new Windows 10 workstation that had Office 365 Plus 32bit installed as well as Visio.  Using SPD I tried accessing an existing SharePoint 2013 list workflow on an O365 SharePoint site, and when opening the workflow, it opened a progress dialog that showed it downloading and building a cache. When done, it popped an alert of something like, "Server side activities updated... restart SPD to use latest activities".  I did re-launch SPD and then when opening the workflow I got the "Windows Workflow Foundation, part of .Net Framework 3.0, must be installed to use this feature." message.

    I cleared the files from the caches, as indicated elsewhere in this post:

    • %LOCALAPPDATA%\Microsoft\WebsiteCache\
    • %APPDATA%\Microsoft\SharePoint Designer\ProxyAssemblyCache\
    • %APPDATA%\Microsoft\Web Server Extensions\Cache\

    That did not help, and so I looked at those hot fixes. They were released in 2014 before SPD SP1 was released, and so I'd expect them to be included in SP1, but maybe not. I specifically only installed 2837667 because it is the only one that addresses a workflow problem. Specifically, it says this was a fix included in it:

    SharePoint Designer cannot load the existing workflows that contain disconnected stages, and you receive an error message when the loading fails. 

    After installing the hot fix, I launched SPD and was able to successfully open the workflow.  My advice to others is to do as I did and clear the caches, install that one hot fix even if you have SPD SP1, and then launch SPD to see if it worked.

    Good luck, my friends.


    Wednesday, January 10, 2018 9:57 PM