none
Shared Addin not loaded error. RRS feed

  • Question

  • Hi,

    I'm trying to develop a Shared Addin for Excel, Work and PowerPoint. Here's my dev env :

    Win7 x64, Office 2010 x64, VS 2010 SP1

    I created a default Shared Addin (C#, All users, Load at startup, .Net 4) and try it under Excel (changed Startup program) but the addin is not loaded with the following error "Not loaded. A runtime error occured during the loading of the COM Add-in.".

    I've tried debugging and break on any exception (Managed, Win 32, C++) but cannot get into the code.

    Anyone has an idea of what i'm doing wrong ?

    Thanks,


    Guillaume Rouchon - MVP VisualStudio ALM - Blog : http://blog.qetza.net
    Wednesday, September 7, 2011 10:23 AM

Answers

All replies

  • Hello,

    First, check if LoadBehavior is 3 in {HKLM or HKCU}\Software\Microsoft\Office\Outlook\Addins\{your add-in}. 3 - means "load at startup and start the add-in". A run-time error sets LoadBehavior to 2.

    Also, when debugging an add-in, always close the debugging session by closing Outlook. Otherwise, Outlook may put your add-in to the Disabled Items (see File | Options | Add-ins | Manage {Disabled Items}, Go).

    Pay attention that since your Outlook is 64 bit, your add-in and its dependecies must be 64 bit, too.


    Regards from Belarus (GMT + 2),

    Andrei Smolin
    Add-in Express Team Leader
    Wednesday, September 7, 2011 11:03 AM
  • Hi Andrei,

    Thanks for the reply. The LoadBehavior is 3 but after starting Excel it gets to 2 since the add-in wasn't loaded correctly. It's not in the disabled items.

    To support 64bit, i have updated the setup project to target x64 and also tried to pass the addin to x64 and customize the post build to use regasm x64 but still the add-in won't load.

    I enabled fusion log but got nothing...

    I'll try to install a x32 version of Office to see if the problem is on x64.

    Thanks,


    Guillaume Rouchon - MVP VisualStudio ALM - Blog : http://blog.qetza.net
    Wednesday, September 7, 2011 2:19 PM
  • You trying to get the break point using debug mode right ?

    Can you inherit IExtensibility2 and write your own addin to test this ?


    Thanks Sameer Kamarudeen
    Monday, September 12, 2011 8:49 PM
  • will this help?

    http://support.microsoft.com/kb/921541

     


    Thanks Sameer Kamarudeen
    • Marked as answer by Bruce Song Monday, September 19, 2011 7:06 AM
    Monday, September 12, 2011 9:30 PM
  • will this help?

    http://support.microsoft.com/kb/921541

     


    Thanks Sameer Kamarudeen
    Monday, September 12, 2011 9:31 PM
  • Hi Guillaume Rouchon

    Were you able to resolve the issue that you have posted. I have the same issue? Can you please post the resolution for this issue?

     

    Thanks

    Sandy

    Wednesday, December 21, 2011 11:51 AM