Migrated to new Win2019/IIS10 and Classic ASP is not working... RRS feed

  • Question

  • User363466404 posted

    Hello, everyone!

    I have migrated from a Windows Server2008 R2 machine to a new Windows Server 2019 install. I have a Classic ASP app that I'm trying to get back up. But I keep getting the following error message,

    An error occurred on the server when processing the URL. Please contact the system administrator.

    If you are the system administrator please click here to find out more about this error.

    I've added ASP, ISAPI Extensions, ISAPI Filters, and Server Side Includes.

    The ASP ISAPI filter is configured in the root of the app and enabled.

    I've created a "No managed code" app pool that's using the classic pipe.

    I'm kind of at a loss for how to move forward. What am I missing here?

    Saturday, June 20, 2020 12:31 AM


All replies

  • User-460007017 posted

    Hi MissAmberClark,

    Its important to get detailed error message and root cause. Please set IIS manager->Site node->ASP->Send error to browser. Please post the full error message. Besides, what error message did you see in event viewer?

    Failed request tracing can also help troubleshooting this issue:


    Have you tried general troubleshooting steps like change application pool identity to local system or enable 32 bit application?

    Best Regards,

    Jokies Ding

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, June 22, 2020 7:20 AM
  • User363466404 posted

    Ah ha! The link to a document saying that ASP is not installed by default was a red herring. 

    I originally went to go turn on error messages to the browser and did not see it. I did a bit more digging through and found it under IIS Manager->Site -> ASP -> Debugging -> Send error to browser.

    That revealed an underlying SQL failure that I was able to go fix.

    Thank you!

    Monday, June 22, 2020 1:55 PM