locked
IIS Application Warm-Up Module for IIS 7.5 on windows server 2008 R2 and windows 7 RRS feed

  • Question

  • User1964421729 posted

    I've installed IIS Application Warm-Up Module for IIS 7.5 on windows server 2008 R2 64x , but it's not visible on IIS , so is there any other configurations to get use of IIS Application Warm-Up Module ???

    Monday, July 2, 2012 5:11 AM

All replies

  • User-218459230 posted

    Hi HSabatin,

    Once you install the Application Initialization Module for IIS 7.5 - Release Candidate, it shoudl be available to IIS. However there are no UI elements to configure this module. http://forums.iis.net/t/1176740.aspx 

    This post also references an article to help setup and configure Application Initialization.  http://learn.iis.net/page.aspx/1089/iis-80-application-initialization/

    Please let me know if this helps you.

    Monday, July 2, 2012 10:31 AM
  • User1964421729 posted

    thank you for your kind replay , i've followed the article , but the application warm-up moudle not visible on the IIS 7.5 to be able to configure any installed application , so i don't know what is the problem in the IIS 7.5 itself or i have something missing

    Saturday, July 7, 2012 7:54 AM
  • User-218459230 posted

    Hi HSabatin,

    There is no GUI user interface to configure this feature.  Currently you must configure it using the applicationHost.config at the machine-wide level or using the the web.config files at the site or application level. 

    This article walks through the various settings and how to configure the files:

    http://learn.iis.net/page.aspx/1089/iis-80-application-initialization/#TOC301258517

    In IIS Manager you can use the "Configutation Editor" to verify that Application Initialization was installed and configure a few settings.

    - Open IIS Manager

    - Open Configuration Editor

    - Go to config section "system.webServer/applicationInitialization"

    - Modify settings for Application Initialization

    Saturday, July 7, 2012 12:01 PM
  • User1964421729 posted
    Hi ,I’ve applied all the written steps , but I still have the same problem with first time running is slow , it takes about 10 seconds to navigate to home page , then next time it’s too fast<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>
    Sunday, July 8, 2012 5:08 AM
  • User-218459230 posted

    Hi HSabatin,

    You most likely need to wait for the application to finish initializing on the first load. 

    Are you using the splash page while waiting for the application to initialize? 

    I believe the idea here is to display a static page while your dynamic content pages initialize in the background. 

    Sunday, July 8, 2012 5:06 PM
  • User-218459230 posted

    Hi HSabatin,

    There are two things that need to be set in the applicationHost.config file. The application pool needs to be set to startMode="AlwaysRunning".  And the site needs to be set needs the perloadEnabled="true" attribute set.

    <applicationPools>

      <add name="appinit" autoStart="true" startMode="AlwaysRunning" managedRuntimeVersion="v4.0" />

    </applicationPools>

     <sites>
            <site name="Default Web Site" id="1" serverAutoStart="true">
                <application path="/">
                    <virtualDirectory path="/" physicalPath="%SystemDrive%\inetpub\wwwroot" />
                </application>
                <application path="/appinit" applicationPool="appinit" preloadEnabled="true">
                    <virtualDirectory path="/" physicalPath="C:\inetpub\wwwroot\appinit" />
                </application>
            </site>
    </sites>

    Saturday, July 14, 2012 1:38 PM