locked
ribbon stuck on loading condition RRS feed

  • Question

  • Hi all,

    I've got this problem with the ribbon in my site.

    It stuck on loading condition.

    So when I choose Page from the ribbon, it only show "loading".

    thank you all


    Best regards,
    -- Pingkan --
    Monday, September 27, 2010 4:56 AM

Answers

  • I have a similar issue on some clients when selecting the Page Tab from the top ribbon of my SharePoint 2010 site the page shows "Loading" and doesn't display the ribbon options (edit page, etc).

    So far seen this with two Windows 7 laptops, different users accounts but both users were Team Site Owners for the site.

    Managed to resolve the issue for one of the users by changing the application pool account against the /_vti_bin/sts virtual path in IIS from "SecurityTokenServiceApplicationPool" to  SharePoint - 80.  Post is here: http://software.feedfury.com/content/40327315-sharepoint-2010-javascript-errors.html

    This allowed one of the users to see the ribbon options OK but still the other user only see's the Loading dialog in both the team site & central admin site.

    Have also tried Enabling & Disabling static & dynamic compression for the site having the issue.

    Would welcome any suggestions on what could be causing this and any steps to resolve this issue.

    Thanks, Eildon IT.

     

    • Proposed as answer by rr230587 Monday, May 16, 2011 7:19 PM
    • Marked as answer by Pratik Vyas Monday, August 5, 2013 4:29 PM
    Monday, September 27, 2010 10:49 AM
  • If we have ISA we can try the following:
    Turning on ‘compression filter’ in ISA has fixed the problem with the ribbon not loading.

    If the client machine running Windows XP SP3 and Internet Explorer 7 then try the following:
    Edit the following key in the registry-
    [HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
    "ProxyHttp1.1"=dword:00000001
    When the registry key has the value 1 for Proxy HTTP 1.1

    Also, check the patch level for the Office Applications on the clients along with Internet Explorer & confirm if thay are the same.

    Confirm if we are using Windows XP SP3 client.

    Enable IE Advanced options > HTTP 1.1 Settings > Use HTTP 1.1 and Use HTTP 1.1 through proxy connections”.


    Fred Ellis - MSFT - "Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread."
    • Proposed as answer by Fred El - MSFT Wednesday, November 17, 2010 3:05 PM
    • Marked as answer by Pratik Vyas Monday, August 5, 2013 4:29 PM
    Tuesday, November 2, 2010 1:57 PM

All replies

  • I have a similar issue on some clients when selecting the Page Tab from the top ribbon of my SharePoint 2010 site the page shows "Loading" and doesn't display the ribbon options (edit page, etc).

    So far seen this with two Windows 7 laptops, different users accounts but both users were Team Site Owners for the site.

    Managed to resolve the issue for one of the users by changing the application pool account against the /_vti_bin/sts virtual path in IIS from "SecurityTokenServiceApplicationPool" to  SharePoint - 80.  Post is here: http://software.feedfury.com/content/40327315-sharepoint-2010-javascript-errors.html

    This allowed one of the users to see the ribbon options OK but still the other user only see's the Loading dialog in both the team site & central admin site.

    Have also tried Enabling & Disabling static & dynamic compression for the site having the issue.

    Would welcome any suggestions on what could be causing this and any steps to resolve this issue.

    Thanks, Eildon IT.

     

    • Proposed as answer by rr230587 Monday, May 16, 2011 7:19 PM
    • Marked as answer by Pratik Vyas Monday, August 5, 2013 4:29 PM
    Monday, September 27, 2010 10:49 AM
  • If we have ISA we can try the following:
    Turning on ‘compression filter’ in ISA has fixed the problem with the ribbon not loading.

    If the client machine running Windows XP SP3 and Internet Explorer 7 then try the following:
    Edit the following key in the registry-
    [HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
    "ProxyHttp1.1"=dword:00000001
    When the registry key has the value 1 for Proxy HTTP 1.1

    Also, check the patch level for the Office Applications on the clients along with Internet Explorer & confirm if thay are the same.

    Confirm if we are using Windows XP SP3 client.

    Enable IE Advanced options > HTTP 1.1 Settings > Use HTTP 1.1 and Use HTTP 1.1 through proxy connections”.


    Fred Ellis - MSFT - "Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread."
    • Proposed as answer by Fred El - MSFT Wednesday, November 17, 2010 3:05 PM
    • Marked as answer by Pratik Vyas Monday, August 5, 2013 4:29 PM
    Tuesday, November 2, 2010 1:57 PM
  • I have the same issue, but I'm running Windows 2003 R2 with service pack 2 through a citrix session.  SharePoint is not installed on this machine.  I'm the site collection and farm admin, but I have restricted access on this client.  HTTP 1.1 advanced settings are enabled.

    I think this is related.  I'm in the site pages library of a team site and when I click on add new page, nothing happens.  The ribbon above it is just showing loading.


    Will D. Robinson
    Monday, November 22, 2010 3:04 PM
  • Any suggestion to solve the problem ???
    Monday, May 16, 2011 7:19 PM
  • Hi

    Can you confirm if this is happening at the Top level site ?

    i had this problem when i was messing around with the master pages in sharpoint designer. i managed to fix it by using a different master page.

    Try creating a new page via Sharepoint Desingn and see if that work,

    Is there any error logs on the sharepoint server that could help ?

    also

    what if you create a new page ? does it still say "loading"

    any chance of a screenshot etc...

    Cheers

    Alistair

    Tuesday, May 17, 2011 6:18 PM
  • Hi, One of the cause of this problem is due to the DNS Devolution that Microsoft introduced in the newer Windows version. If you have a "." in your host name, you will need to Enable "Allow DNS Suffix Appending to Unqualified Multi-Label Name Queries". I have put the details in my blog: http://sharepointegg.blogspot.com/2011/06/sharepoint-2010-ribbon-stuck-at-loading.html Wilson
    Wilson | SharePoint Egg's Blog
    Friday, June 10, 2011 2:35 AM
  • "Enable IE Advanced options > HTTP 1.1 Settings > Use HTTP 1.1 and Use HTTP 1.1 through proxy connections”

     

    This worked for me on Win XP sp3 & IE 8, Thanks!

     

    Wednesday, July 13, 2011 8:24 AM
  • Hi all,

    I just had the same problem. Thanks to Alistair4267 I found the solution in my master page. I have a lot of custom Ribbon UI added to my site but that was not the problem (It could of course be if there were any syntax errors)

    My problem was solved when I restored my master page. I had removed the built in Top Navigation and replaced it with my own. Funny thing is that Calendars were working OK but any other type of list had the Ribbon "Loading" problem. Now I've readded Top Navigation but inside a <div style="none;"> section ;) Don't know why the Ribbon is dependent on "Top Navigation" other than hiding it... which works for Calendars..

     

    • Proposed as answer by AfisITzone Monday, October 15, 2012 9:40 AM
    Thursday, July 28, 2011 8:39 AM
  • I had a similiar issue.

    I tracked it down, using the IE developer tools, to a Java script error I had inside a content editor, which I embeded into the Quick Launch.

    Obviously the code exception was aborting script execution, breaking the ribbon.

     

    The code was this: http://social.technet.microsoft.com/Forums/en-US/sharepoint2010programming/thread/28ef9b01-57e9-448a-ba36-f1e68ad1e915

    Monday, August 22, 2011 2:09 AM
  •  

    Hi this morning my work winxp sp3 laptop crashed.   Yes you got it,  I have the "ribbon bar loading" issue.  Curiously,  this only occurs in IE8 and not if FF 3.51.  In both cases I am not going through a home wifi connection so no proxy.

     

    I have  checked Enable IE Advanced options > HTTP 1.1 Settings > Use HTTP 1.1 and Use HTTP 1.1 through proxy connections”  and these were set correctly. The registry [HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings] "ProxyHttp1.1"=dword:00000001 is simply reflecting this.

    I am a bit of a loss

    You do get a JavaScript error but given the list site renders correctly in FF the issue is with the way IE 8 talks to SharePOint.

     

    Webpage error details
    
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET4.0C; .NET CLR 1.1.4322; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0E; InfoPath.3; MS-RTC LM 8)
    Timestamp: Fri, 23 Sep 2011 12:08:22 UTC
    
    
    Message: Expected ':'
    Line: 2
    Char: 20363
    Code: 0
    URI: https://mycompany.com/_layouts/sp.ribbon.js?rev=F%2BJJJ66rbXzSvpf7nN70wQ%3D%3D


    Friday, September 23, 2011 3:18 PM
  • I know this is an old post, but I also had commented out the default navigation to substitute it with my own. I un-commented it and now the ribbon works just fine. I'm curious also why one thing would depend on another. Now, if only I can manage to "hide" the default navigation without commenting the code....

    Update: To hide the default navigation without commenting the code, just put it all in a div with "display:none;" :)

    • Edited by mcolon Monday, March 5, 2012 3:27 PM
    Thursday, February 23, 2012 6:27 PM
  • Hi All,

    I have a similer kind of issue but not the same. I have used ribbon bar to design my website. Its working fine in all other browser. But its breaking in google chrome only while switching over.

    Thanks,

    Koushikp

    Tuesday, March 13, 2012 7:16 AM
  • I had a similar issue.  I resolved this by replacing comments from the masterpage where code blocks had been commented out; so for example, where a code block was commented out using <!-- I replaced the comment with the ASPX style <%-- and closed it with --%>

    This worked for me, the ribbon is now fine.

    Wednesday, July 4, 2012 8:55 AM
  • I tried it also, but not working.

    I am using through Citrix on IE8 and server is windows 2003.

    Friday, September 21, 2012 3:42 PM
  • Thanks _Kefir_ ,

    Hiding the top navigation in a div with "display:none" instead of commenting it out solved this problem that was occurring with my custom master page. The ribbon now loads on all pages.

    Monday, July 15, 2013 4:15 PM