none
Object store as a root filesystem RRS feed

  • Question

  • Hi,

    When I load Object Store as a root file system (SYSGEN_FSRAMROM is set). I also use ram-based registry. It gives the following messages

     Unknown: DEBUGCHK failed in file d:\chelanrtm14\private\winceos\coreos\filesys\reg\profiles\secstor.h at line 487
    PID:00400002 TID:00510002 DEBUG_BREAK @efd8e7c4 Ignored.
    PID:00400002 TID:00510002 Unable to read Dynamic DST information for time zone Pacific Standard Time.
    PID:00400002 TID:00510002 Value [Locale] without corresponding LCType in NLS Override section
    PID:00400002 TID:00510002 Value [LocaleName] without corresponding LCType in NLS Override section
    PID:00400002 TID:00510002
    Initializing Database
    PID:00400002 TID:00510002 SetCurrentUser: User hives not supported -- using same registry for all users
    PID:00400002 TID:00510002 FSDMGR: DEBUGCHK failed in file d:\chelanrtm14\private\winceos\coreos\storage\fsdmgr\volumeapi.cpp at line 402
    PID:00400002 TID:00510002 DEBUG_BREAK @ef942bf4 Ignored.
    PID:00400002 TID:00510002 Unknown: DEBUGCHK failed in file d:\chelanrtm14\private\winceos\coreos\filesys\reg\profiles\secstor.h at line 487
    PID:00400002 TID:00510002 DEBUG_BREAK @efd8e7c4 Ignored.

    What is happening there in private parts? What is the reason for this messages?

    I am also interested how registry is loaded in Object Store from Rom. I am not able to use either Flash memory nor any external disks at the moment. So Only RAM is available.  I assume it goes like this (in brief):

    1. platform.reg overrides common.reg

    2. a new common.reg is put into an image file.

    3. filesys.exe loads Storage Manager, which creates Object Store file system. All the system files are copied from the image to the RAM (OBJECT STORE)

    Question here: Does Object store need any registry settings? If it does where does it obtain them if root file system has not been created and nothing has been copied? Directly from ROM (common.reg)? Somewhere else?

    It is all very confusing for me.

    Thanks in advance. I hope that someone can shed light on this all.


    P.S: Forgot to add that later it crashes when it tries to load font files. The reason for that is not known.
    Tuesday, August 30, 2011 12:00 PM

All replies

  • Hi,


    What is happening there in private parts? What is the reason for this messages?


    I guess that you are using WEC7?
    If yes, these DEBUGCHKs are WEC7 "early bug". MS guys tries to solve it, as they report about it  :-/

    http://social.msdn.microsoft.com/Forums/en-US/winembplatdev/thread/726c1c58-5679-4c2e-ab1c-a3aa47b5cecf

     

     

     

    Tuesday, August 30, 2011 12:53 PM