none
Why does visual studio 2015 lock up after pinging the microsoft licence server? It's killing me!

    Question

  • Every few minutes VS 2015 pings licensing.mp.microsoft.com:443

    this call returns 200 OK.

    Then visual studio locks up completely for 15~30 seconds occasionally long enough for VS to pop up that hmm something is busy dialog but I have no idea what.  

    This is so frustrating.  I thought is I registered VS with a Key (Which I have) it would stop pinging the licence server.

    I have correlated this lock up using fiddler and monitoring the issue for a couple of days.  It's always:

    • GET licensing.mp.microsoft.com:443
    • Block user for ages, at least until his hair falls out.
    • let him work for a couple of minutes
    • Repeat till he lives no more.

    I know you need to protect your software, but why check every few minutes.  if my licence was good 5 minutes ago, why would that be different now, or 5 minutes into the future.  Can you not reduce the period between call to once an hour or something?

    Or better yet - Get of the UI thread!


    ltheONEl

    Wednesday, May 25, 2016 6:43 PM

Answers

  • Hi,

    I had some trouble with Visual Studio checking if the license is valid or not (which was some proxy problems so the cause was soemthing else) and I was able to solve my issue through entering my license key.

    So if you have a MSDN subscription, then you can find your product key inside your product keys and enter it.

    This only works if you have a MSDN subscription of course. I have no idea if there is such a path for the community edition (I think not, because I know threads regarding offline registration of the community edition).

    With kind regards,

    Konrad

    Monday, May 30, 2016 9:09 AM
    Moderator

All replies

  • Hi ltheONEl,

    Which VS2015 version did you use?

    >>Every few minutes VS 2015 pings licensing.mp.microsoft.com:443

    >>I have correlated this lock up using fiddler and monitoring the issue for a couple of days. 

    Could you share us the detailed step about how we could repro this issue? How can we check that the VS always pinging the license server? Do you mean you use the Fiddler tool or others?

    If possible, please share us the steps about how we could repro this issue, you could also upload simple screen shots in your reply, so we could understand and repro this issue easily.

    In addition, as far as I know, VS IDE has some settings which will update the VS, not very sure that whether it will impact the license or the communication between the client and server side, maybe you could disable it, check it again.

    If still no help, please feel free to share us the steps about how to repro this issue, I will test it in my side.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, May 26, 2016 8:51 AM
    Moderator
  • Hi ltheONEl,

    Any updates?

    Would you mind letting us know the latest information about this issue?

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, May 30, 2016 8:27 AM
    Moderator
  • Hi,

    I had some trouble with Visual Studio checking if the license is valid or not (which was some proxy problems so the cause was soemthing else) and I was able to solve my issue through entering my license key.

    So if you have a MSDN subscription, then you can find your product key inside your product keys and enter it.

    This only works if you have a MSDN subscription of course. I have no idea if there is such a path for the community edition (I think not, because I know threads regarding offline registration of the community edition).

    With kind regards,

    Konrad

    Monday, May 30, 2016 9:09 AM
    Moderator
  • Sorry its a holiday weekend here, will try to update tomorrow.

    ltheONEl

    Monday, May 30, 2016 2:31 PM
  • Thanks for Konrad's help.

    Hi ltheONEl,

    We look forward to hearing from you, if you get any latest information, please feel free to let us know.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, May 31, 2016 5:24 AM
    Moderator