none
Visual Studio 2017 Reporting strange behaviour

    Question

  • Hi all,

    I have some strange behaviour while creating reports. If I create a report (rdlc) for the first time, and making some changes to it (hide, view columns, add a page header etc) all went fine. The report is just showing up in the report viewer while running my application. And if I open the rdlc file in Notepad the following line for the schema is showed

    <Report xmlns="http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition"

    But, I don't know exactly when this is happening, if I made a modification to the report like adding a text box with a report parameter in it, and run my application, I get the following error:

    The definition of this report is not valid or supported by this version of Reporting Services. The definition has an invalid target namespace http://schemas.microsoft.com/sqlserver/reporting/2016/01/reportdefinition which cannot be upgraded.

    If I check my rdlc with Notepad, there is a line like this:

    <Report xmlns="http://schemas.microsoft.com/sqlserver/reporting/2016/01/reportdefinition"

    which gives an error.

    I don't know why this line is changed. if I create the report for the first time its 2008 and after some modifications it's changed to 2016 which gives me an error.

    Any Ideas?

    Regards,

    Mark Hofland

    Thursday, April 20, 2017 12:59 PM

Answers

  • Hi Karen,

    In the mean time I figured out how to solve my problem. I downloaded the latest Report Viewer for VS 2017 via NuGet, and all seems to be fine now.

    Still don't know why it's changing from 2008 to 2016, but till now no error messages.

    Regards,

    Mark

    Thursday, April 20, 2017 2:58 PM

All replies

  • I would suggest reporting the bug using the following link.

    https://connect.microsoft.com/VisualStudio


    Please remember to mark the replies as answers if they help and unmark them if they provide no help, this will help others who are looking for solutions to the same or similar problem. Contact via my Twitter (Karen Payne) or Facebook (Karen Payne) via my MSDN profile but will not answer coding question on either.
    VB Forums - moderator
    profile for Karen Payne on Stack Exchange, a network of free, community-driven Q&A sites

    Thursday, April 20, 2017 1:19 PM
    Moderator
  • Hi Karen,

    In the mean time I figured out how to solve my problem. I downloaded the latest Report Viewer for VS 2017 via NuGet, and all seems to be fine now.

    Still don't know why it's changing from 2008 to 2016, but till now no error messages.

    Regards,

    Mark

    Thursday, April 20, 2017 2:58 PM