locked
Cannot pair with latest Xamarin for Visual Studio with Xamarin Build Host RRS feed

  • Question

  • User37439 posted

    I am using the latest Xamarin stable builds on my Mac and Windows machine. Unfortunately I am no longer able to pair with my Mac. It says no UUID is set after attempting a pairing.

    Wednesday, July 9, 2014 11:51 AM

All replies

  • User57754 posted

    Seems like yet another bug in their latest builds. Read announcement at the top of the forum. Unfortunately none of their work arounds are working for me. Starting to get disappointed by the QA I am seeing. I'm a trial user but starting to wonder if I'll ever go beyond that. Haven't been able to use my trial for over a week now even though they extended it. Was trying to get a working prototype to convince my employers to buy license but all I've shown them is me being unable to use the product so not looking good....

    Wednesday, July 9, 2014 2:29 PM
  • User37439 posted

    I followed the copying of the assemblies and facades in that announcement with no luck. On to uninstalling the latest Xamarin and going back to the previous versions. Xamarin Support, lately the experience with your tools has been much less than stellar.

    Wednesday, July 9, 2014 2:47 PM
  • User18 posted

    Hi @RichardCrane.2330?,

    Thanks for letting us know about the issue! I saw this issue earlier this morning and wrote up a bug report for our Visual Studio Team to further investigate. You may want to cc yourself onto the report to be notified of any updates or fixes to the issue.

    At this point, the only workaround I know of is to downgrade back to Mavericks. However, if I hear of any other workarounds I'll add it here and to the report. Cheers!

    Wednesday, July 9, 2014 3:33 PM
  • User28327 posted

    @AllieMiller? I downgraded back to Mavericks, but it is still not pairing for me. It was paired previously under Mavericks, I don't know how to get it working again. I re-installed all of the Xcode and Xamarin bits just to make sure they were all there.

    Friday, July 25, 2014 2:55 PM
  • User5659 posted

    @EricGrover I experienced the same, after install again Yosemite preview 1 the pairing process Works again. But If you install preview 3 or 4, VStudio will not pair with Build Host.

    Friday, July 25, 2014 9:42 PM
  • User46174 posted

    Just tried pairing Visual Studio 2013 w/Build Host on Yosemite GM. Still fails.

    Friday, October 17, 2014 8:06 PM
  • User44073 posted

    I have same issue :( and it's very frustrating!

    Saturday, October 18, 2014 8:26 AM
  • User44073 posted

    I've disabled the Yosemite Firewall and now works fine :)

    Saturday, October 18, 2014 4:20 PM
  • User46174 posted

    Just confirmed, firewall was already disabled for me on Yosemite. Not working.

    Saturday, October 18, 2014 4:28 PM
  • User13824 posted

    It seems the main focus of this thread is the pairing problem on OS X Yosemite, so I'm going to close this as a duplicate of a new thread about that issue to help consolidate further discussion:
    http://forums.xamarin.com/discussion/26340/os-x-yosemite-the-pin-you-entered-was-invalid

    I added a note on the new thread that it might be possible to work around the problem temporarily adding a network proxy between the Mac build host and the Windows machine. I'm not sure if this will really work, but if anyone has some experience with proxies, please do reply on the new thread to let other users know if this might be possible. Thanks!

    Sunday, October 19, 2014 9:17 PM