none
cannot delete a campture image

    Question

  • Azure appears to work fine for capturing images. My issue is that once captured, I cannot delete the VM images. What am I doing wrong? I've even tried to restart the Source VM.
    Tuesday, November 18, 2014 4:01 PM

Answers

All replies

  • Hi,

    Thank you for reaching out to us.

    I am currently researching to gather more information with regards to your request.

    I shall revert back to you with an update at the earliest.

    Sincerely appreciate your patience.

    Regards,

    Shirisha Paderu

    Tuesday, November 18, 2014 7:20 PM
    Moderator
  • Hi FairDocument,

    We might have to delete the vhd first to delete the image otherwise we cannot delete the captured VM image

    We can delete the Azure captured VM image using the power shell command as shown below :

    syntax :

    SYNTAX

        Remove-AzureVMImage [-ImageName] <string> [-DeleteVHD] [<CommonParameters>]

    Example :

    PS C:\windows\system32> REMOVE-azurevmimage -Imagename PSVM6-2044-261462 -DeleteVHD

    OperationDescription                                            OperationId                                                     OperationStatus                                              

    --------------------                                            -----------                                                     ---------------                                               

    Remove-AzureVMImage                                             36b6f22a-e473-3120-ac07-67498387fb82                            Succeeded                                                    

    see Remove-azurevmimage for more details

    Regards,

    Shirisha Paderu



    Tuesday, November 18, 2014 8:28 PM
    Moderator
  • What is causing the delete button to be grayed out, driving the only resolution to use PowerShell? Is this something we caused or a bug in the portal?
    Tuesday, November 18, 2014 8:32 PM
  • Hi FairDocument,

    There is an on-going issue with the portal [ delete button is disabled for vm image ] since
    yesterday.

    I shall revert back to you with an update at the earliest.

    Sincerely appreciate your patience.

    Regards,

    Shirisha Paderu




    Wednesday, November 19, 2014 4:31 PM
    Moderator
  • Hi,

    Issue is resolved right now, " Delete " button is now enabled.

    Please confirm if this is fixed.

    Regards,

    Shirisha Paderu

    Thursday, November 20, 2014 8:59 PM
    Moderator