none
Promoted properties of the "preserved interchange" RRS feed

  • Question

  •  

    I need to have the doc type available in the promoted properties of the preserved interchange, I have been able to build a schema for this and am able to map from it, but I can not route it becuase the only promoted properties are the ID's and qualifers of the ISA segment I need atleast the GS01 so that my orchestrations will only pick up the document I want to go thru my map, IE 810, 856,

     

    When I create a recieve port of EDI type and drop an 810 both my 810 and 856 orchs fire and bogus data comes out of the 856 orch becuase of the 'global' properties.

     

    Any thoughts out there?

     

     

    Mike

    Friday, October 24, 2008 8:50 PM

Answers

  • I was able to get the files routed by adding a variable, and pointing that to the GS 01 and a decsion point in the orchestration, its all working now.

     

    The problem with the preserved interchange is that the only 5 data points are promoted the the interchange ID's and qualifers and the Test\Production indicator, which to me is not enough. I think that alot of people would like to take advantage of using the preserved interchange and instead of breaking up the file keep it together and then break it up later if need be.

     

     

     

    Mike

     

    Monday, November 3, 2008 5:19 PM

All replies

  • I am a little confused about what you posted. You said a "receive port of EDI type" - is this the Base EDI adapter or a receive port that uses the EdiReceive pipeline or a custom one?

     

    The override of the global properties that clouds what you really want or expect to happen is a huge difficulty that I have seen many times on a current project.  It seems weird that both orchestrations are receiving the message. Do you have overlapping send port filters or do your filters match the EDI global properties? I would avoid setting the EDI global properties to any routable values because this can make debugging very confusing. Then I would look for other properties like InboundTransportLocation or ReceivePortName which can indirectly help you distinguish the message type.

     

    Thanks,

     

    Monday, October 27, 2008 4:02 AM
    Moderator
  • I have one recieve port for this trading partner that is set to EDI Recieve, so that what ever EDI document they send gets picked up and translated to XML for mapping I then have Orchestrations running bound to that port, that pick up the EDI files and run thru the orchestration, the od thing is that in Biztalk 2004 if you ran a file thru a map that was not the correct schema the map would fail, this is not the case in 2006 lets say I ran an 810 in xml format thru my 856 map, it will run and bad output comes out of the map, which I find very stange behavoir. I may have to promote some properties on all my EDI schemas that I have built and use those on the filters.

    Monday, October 27, 2008 1:52 PM
  • Are you using the message type of XmlDocument for your message in your orchestration? If so, this is why the map always runs. I usually have type-specific maps for each trading partner and/or EDI message type. You can filter by ST01 to distinguish a message type to different receive ports.

     

    Thanks,

    Monday, October 27, 2008 2:32 PM
    Moderator
  • No I am using the schema that I have built for each doc type 810, 856, I think the problem is that no matter what I do it reverts to global properties, I have even promoted properties on the EDI schemas, set them to always track and when I drop the files and look at the context, the properties that I promoted are not in the context. and remember I am using preserve interchange, what I want is the entire EDI file to move thru the system, I then map it to a Batched version of our internal schema, so that if a trading partner that is not doing EDI X12 I can then break it up via a recieve pipeline and send out single files. Using the ST01 is not an option in the preserve interchange( as it is not a promoted property, Only the ISA 05, 06, 07, and 08, I have even assigned variables in the orchestration to filter out the different doc types based on the GS 01 and yet both orchs still fire, (And bogus data comes out)I have also created send and receive pipelines based on my internal files and when I use those on a receive location I would think that if the xml file getting to that port where not vaild according to the document set in the receive pipeline that it would fail but that is not the case. So I am at a loss as to what to do in order to get this working.

    Monday, October 27, 2008 2:49 PM
  • Hi,

     "preserve interchange" works only if incoming document is map to a party. It shouldn't be taking the EDI Global properties. Can you give details about filters on orchestrations?

    Friday, October 31, 2008 8:38 AM
  • I was able to get the files routed by adding a variable, and pointing that to the GS 01 and a decsion point in the orchestration, its all working now.

     

    The problem with the preserved interchange is that the only 5 data points are promoted the the interchange ID's and qualifers and the Test\Production indicator, which to me is not enough. I think that alot of people would like to take advantage of using the preserved interchange and instead of breaking up the file keep it together and then break it up later if need be.

     

     

     

    Mike

     

    Monday, November 3, 2008 5:19 PM