locked
an error occurred while has been form submitted RRS feed

  • Question

  • I have an InfoPath form linked to custom list in SharePoint 2007

    And this list have anyone access for adding.

    My problem is if I go to SharePoint and open this list and click New the InfoPath form open and submitted successful .

    But if I open a link from other webpage in our network to this form it open but when click submit it give error “ an error occurred while has been form submitted “

    Please how can I solve this I need to add link to this form to open direct not need to go to sharepoint

    the link that i used is:

    http://kwmoss02/ic/_layouts/FormServer.aspx?XsnLocation=http://kwmoss02/ic/Ideas2/Forms/Form/template.xsn&SaveLocation=http%3A%2F%2Fkwmoss02%2Fic%2FIdeas2&Source=http%3A%2F%2Fkwmoss02%2FPages%2FIdeaSubmitted%2Easpx&DefaultItemOpen=1
    


    Thanks for any help :) my blog is: http://www.waelk.com
    Wednesday, November 9, 2011 8:51 AM

Answers

  • thanks for all your help .

    i found way to make it work i stop the anyone access from all sharepoint and give access to authinticated user as contributed and it is working fine now

    thanks allot


    Thanks for any help :) my blog is: http://www.waelk.com
    • Marked as answer by wael_e Friday, November 11, 2011 11:24 AM
    Friday, November 11, 2011 11:24 AM

All replies

  • Hi,

    So it is an URL problem since it work inside you library or list...

    You just have to copy the url when you open the form from the list or library and change the "source" parameter to set the place where you want to go when the form is submit.

    I think, that in your case, the parameter that can cause problem is "SaveLocation". It explicit the place where the xml of the form has to be save, so you may have done an error with it.

    Hope this help.


    Visit my blog : http://rmatayron.blogspot.com/
    Wednesday, November 9, 2011 1:44 PM
  • thanks for your help but i try to use this link without save location

    http://kwmoss02/ic/_layouts/FormServer.aspx?XsnLocation=http://kwmoss02/ic/Ideas2/Forms/Form/template.xsn&OpenIn=Browser&Source=http%3A%2F%2Fkwmoss02%2FPages%2FIdeaSubmitted%2Easpx&DefaultItemOpen=1
    

    but still same error


    Thanks for any help :) my blog is: http://www.waelk.com
    Wednesday, November 9, 2011 2:53 PM
  • Hi, You must have a "SaveLocation" parameter in your url!!! Without it, the from cannot be submit. Give the right url in this paramter and this will work.
    Visit my blog : http://rmatayron.blogspot.com/
    Wednesday, November 9, 2011 3:05 PM
  • ok i understand you , so i go to the list and open the form and take a copy of URL from browser and it is this:

     

    http://kwmoss02/ic/_layouts/FormServer.aspx?XsnLocation=http://kwmoss02/ic/Ideas2/Forms/Form/template.xsn&SaveLocation=http%3A%2F%2Fkwmoss02%2Fic%2FIdeas2&Source=http%3A%2F%2Fkwmoss02%2Fic%2FIdeas2%2FForms%2FAllItems%2Easpx&DefaultItemOpen=1
    


    and it is have a save location by defualt

    if i take this URL and close browser and open it again diract by past it in the browser it will give me this error .

     the old link for old server it was like this

    http://kwmoss02/_layouts/FormServer.aspx?XsnLocation=/FormServerTemplates/New%20Idea%20Form.xsn&OpenIn=Browser&Source=http%3A%2F%2Fkwmoss02%2FPages%2FIdeaSubmitted%2Easpx&DefaultItemOpen=1

     

    any soluation please?


    Thanks for any help :) my blog is: http://www.waelk.com
    • Edited by wael_e Wednesday, November 9, 2011 3:14 PM add more information
    Wednesday, November 9, 2011 3:11 PM
  • any solutions?
    Thanks for any help :) my blog is: http://www.waelk.com
    Thursday, November 10, 2011 8:00 AM
  • thanks for all your help .

    i found way to make it work i stop the anyone access from all sharepoint and give access to authinticated user as contributed and it is working fine now

    thanks allot


    Thanks for any help :) my blog is: http://www.waelk.com
    • Marked as answer by wael_e Friday, November 11, 2011 11:24 AM
    Friday, November 11, 2011 11:24 AM