locked
Project Windows 8

    Question

  • When I press Ctrl F5 , there is mistakes:

    1>------ Deploy started: Project: MindWave, Configuration: Debug x64 ------
    1>Error : DEP0700 : Registration of the app in the layout folder "C:\project\Win8_Wp7SignalToSms6\MindWave_VS11\MindWave_VS11\MindWave\bin\x64\Debug\AppX" failed.
    1>0x800706D9 : While installing the 76bece3d-bf68-46e3-a355-d23bb021_1.0.0.0_x64__h2qzzvcpwqeye package, the system failed to register the windows.repositoryExtension extension due to the following error: There are no more endpoints available from the endpoint mapper.
    1>.
    ========== Deploy: 0 succeeded, 1 failed, 0 skipped ==========

    This project 3-5 days ago worked correctly, but there was upgrade Win 8. What"s happen? Can anybody help?

    Monday, March 12, 2012 8:49 AM

Answers

All replies

  • Hello,

    what are your firewall settings?  e.g.

    1. Windows Key + R, type in services.msc

    2. scroll down to "Windows Firewall", is it marked as disabled or not running.  If so right click and select properties, set it to "automatic" and start the service.

    Retry the deploy.

    much appreciated,

    mike

    Monday, March 12, 2012 9:17 PM
    Moderator
  • Firewall is not running, but application still not working What ales  wrong? Thanks

    Thursday, March 15, 2012 6:05 AM
  • Hello,

    so the firewall service is now in a running state but you are seeing the same endpoint error or are you seeing a different error?

    Do you see this error with any metro application?  For example, create a new Metro C# application, press ctrl + F5?

    much appreciated,

    mike

    Thursday, March 15, 2012 3:10 PM
    Moderator
  • Hi, yes I  see this error with any metro application, wiht simple ones too.  The firewall service is not  in a running state (manual). The application i try to start works correctly at the other  computer. What can i do to improve situation? 

    Also, the Windows phone 7 application does not work. Emulator of phone  does not work. Please help me. Thanks.

    Friday, March 16, 2012 3:54 AM
  • Hello,

    are you able to start the firewall service so it is in a running state (right click and select "Start") or does it throw an error?  First, put the firewall service in a running state and open up your metro application in Visual Studio, press ctrl + F5.

    thanks!

    mike

    Saturday, March 17, 2012 1:51 AM
    Moderator
  • Hello! metro application works!  Thanks a lot!  I run firewall - and that is all!

    Now I try to run Windows Phone 7 application in VS 2010 Ultimate at the computer with OS Windows 8.

    SP1 installed. Mistake "The target  "GetCopyToOutputDirrectoryContentProjectItems" Does not exist in the project.

    At other computer with OS Windows 7 this application works correctly (emulator starts too).

    Please, help me to run  my   Windows Phone 7 application at comp with OS Windows 8.

    Thanks.


    Saturday, March 17, 2012 7:03 AM
  • Hello,

    so for the Phone 7 issue, definitely take a look at the MSDN blog

    http://blogs.msdn.com/b/astebner/archive/2012/02/29/10274694.aspx

    Look at the How to work around this issue section.

    There is a known issue where XNA Game Studio not installing on Windows 8 Consumer Preview.  XNA Game Studio installs as part of the WIndows Phone SDK.

    After following the instructions in the How to work around this issue section above, I created a Windows Phone Application and also a Windows Phone Silverlight and XNA Application and both built fine.  Does this happen with all Phone 7 applications?

    If the above blog entry doesn't help, check out

    http://forums.create.msdn.com/forums/p/88359/603677.aspx#603677

    In general, http://forums.create.msdn.com/forums/98.aspx is a great resource to help you with Phone 7 SDK related questions.

    much appreciated,

    mike

    • Marked as answer by Jesse Jiang Monday, April 9, 2012 7:00 AM
    Monday, March 19, 2012 8:29 PM
    Moderator
  • Hello!

    Thanks a lot. Your  information is really useful.

    But an emulator Windows Phone 7 does not work in Windows 8. We mast wait the Windows Phone 7 sdk for Windows 8?


    • Edited by Lyudmila Elkina Wednesday, March 21, 2012 3:38 AM grammatic mistakes
    Wednesday, March 21, 2012 3:04 AM