locked
the new PCs run Access very slow RRS feed

  • Question

  • not on-site - - but have been told several PCs were replaced with new hardware PCs & Office 365....and that a long established correctly split Access application is now crazy slow on just those PCs.....10s of seconds to open the Start form, etc.

    so it's all the latest & greatest - but crazy slow.... naturally it only is affecting the Access application...the PCs that have not been changed out still operate fine...  in fact one power user had to go back to their old PC just in order to keep their productivity going....

    have asked that anti virus be turned off, and verified these are not wireless PCs, and gave them instructions on setting up trust locations which am told was done....

    have perused this topic with a variety of suggestions across the years....nothing grabs me i.e. non-existing table links (none of those)...  no remote network printer (there is a local printer)...UNC linking to BE...   any one have this issue??

    Wednesday, August 12, 2020 8:54 PM

Answers

  • In the task manager, try setting the cpu affinity to a single core.

    Daniel Pineault, 2010-2019 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net

    Wednesday, August 12, 2020 9:42 PM
  • Hi,

    What I'm going to suggest might not be a solution.

    Go to "Turn Windows features on or off" - just key-in into the windows 10 search bar.

    Check - "SMB 1.0/CIFS File Sharing Support" check all   or

    "SMB Direct" - not sure about this one but it should be checked if the user had full access install (not runtime).

    HTH

    Tuesday, August 18, 2020 6:41 AM
  • Final update; while the suggestions provided were helpful and I marked as solutions - in the end were not.... so the infrastructure guys totally punted - - insisted something was wrong with the Access app... they had "exhausted every possibility"....  keep in mind the problem is only on some of the brand new PCs they provided - only... so their conclusion was obviously not correct, no matter how exhaustive they said they had been..

    But I'm not a PC install guy and don't know all the options out there - - but I went on site just to check things out, not really confident I could do anything to help the situation - - and I see these new PCs are these small book-size and they have a wifi antenna..  I had long past told them it could not work on wifi and they insisted it was not - - in fact they did have an ethernet cable installed and it does seem like it was working via the cable but they had left all the wifi features on.  At Network Settings I optioned OFF every wifi option I could find - and bingo - the response time returned to normal....

    so that was it in the end.  

    Tuesday, September 1, 2020 7:33 PM

All replies

  • In the task manager, try setting the cpu affinity to a single core.

    Daniel Pineault, 2010-2019 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net

    Wednesday, August 12, 2020 9:42 PM
  • hey have never heard of that at all....   will send that idea along....

    I should have mentioned...the IT guys started with Office365 - 64bit edition and the app threw errors like crazy....and that's when I was first called...and told them to change to 32bit edition; the client is not a power user of excel or PowerBI and has no need for 64bit Office....and that resolved the errors....

    did a compact/repair and replaced the FE so to be sure the 64bit attempts are not using a corrupted FE....

    but it all makes me wonder if the Office365 install is goobered up in some way......

    Wednesday, August 12, 2020 10:20 PM
  • It's a really weird issue, but seeing the affinity to one cpu usually solves the issue.  Then you can create a VBS or shortcut file to do this automatically.

    No one has said so, but I suspect it has to do with specific hardware combinations.


    Daniel Pineault, 2010-2019 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net

    Wednesday, August 12, 2020 10:22 PM
  • Hi,

    What I'm going to suggest might not be a solution.

    Go to "Turn Windows features on or off" - just key-in into the windows 10 search bar.

    Check - "SMB 1.0/CIFS File Sharing Support" check all   or

    "SMB Direct" - not sure about this one but it should be checked if the user had full access install (not runtime).

    HTH

    Tuesday, August 18, 2020 6:41 AM
  • thanks AV - will pass that along....   they haven't replied to DP's advice...  the IT guys kind of have a bad attitude and blame this on Access....
    Tuesday, August 18, 2020 1:05 PM
  • Can't exactly blame them with the need to mess around with process affinity to make a program work and all the recent bugs.

    Daniel Pineault, 2010-2019 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net

    Tuesday, August 18, 2020 5:07 PM
  • haven't gotten feedback from the IT group... not sure I ever will....

    but marking the 2 inputs both as answers... thanks for your time...

    no reason to hold this string open....

    Friday, August 21, 2020 4:10 PM
  • Final update; while the suggestions provided were helpful and I marked as solutions - in the end were not.... so the infrastructure guys totally punted - - insisted something was wrong with the Access app... they had "exhausted every possibility"....  keep in mind the problem is only on some of the brand new PCs they provided - only... so their conclusion was obviously not correct, no matter how exhaustive they said they had been..

    But I'm not a PC install guy and don't know all the options out there - - but I went on site just to check things out, not really confident I could do anything to help the situation - - and I see these new PCs are these small book-size and they have a wifi antenna..  I had long past told them it could not work on wifi and they insisted it was not - - in fact they did have an ethernet cable installed and it does seem like it was working via the cable but they had left all the wifi features on.  At Network Settings I optioned OFF every wifi option I could find - and bingo - the response time returned to normal....

    so that was it in the end.  

    Tuesday, September 1, 2020 7:33 PM
  • Appreciate the feedback and you coming back here!

    It turns out we EVEN see this when the computer has only ONE network card, but they have TWO networks setup.

    So, you see the company “domain” and then also say the windows WORKGROUP in the network.

    So, now, Access (or other programs) have to check both networks. So this issue often crops up on laptops. (Their Wi-Fi is on).

    However, as noted, even computers with single network cards ALSO can have this problem when more than one network is setup on that computer. (Say two workgroups, or VERY often we see workgroup was/is setup as one network, and then ALSO the company “domain” logon and network.

    Now, Access has to “try” and resolve the \\COMPUTER NAME for sql server, or even shared printers – it can be really slow.

    As a result?

    We OFTEN find that using the RAW IP address for shared folders or even SQL server fixes this problem. (Because this 100% by-passes the network names resolution process – which as you found out can be VERY slow).

    So, even with one network card, you often see this issue. But with TWO network cards, then yes the problem is even more prevalent.

    So, one way to avoid this is to use raw IP address and no computer names resolutions. However, if that workstation has or uses shared printers, then again access does “talk to” and inquire about printer information – EVEN does this on a form load. So, unless everything (printers, shared folders) use IP address, then two networks can really cause huge delays.

    But, we have found jumping to IP address for shared folder or sql server often solves this issue.

    And printers that don’t exist, or point to non-existing network printers? This again can cause large delays in Access, and is one more area to be aware of.

    But, all in all, good news for you.

    And ALSO very good for the community that can now be aware of this issue.

    So, multiple networks (1 card, or 2 cards) is obviously something that needs to be “high” on the check list of issues to check in the future – we all benefit GREATLY by you coming back and sharing this – the community thanks you VERY much.

    Regards,

    Albert D. Kallal (Access MVP 2003-2017)

    Edmonton, Alberta Canada



    Sunday, September 6, 2020 4:40 PM
  • great input AK...  one question: using normal Link Table Manager to set up a link to the BE - - it relies on standard File Explorer and so how is the core IP address entered for the link?

    Sunday, September 6, 2020 4:50 PM
  • You in general will get a file dialog prompt, or the "browse" option when you launch the linked table manager.

    So, you can enter the server ip and folder (or file) like

    So in above, you can enter something like:

    \\192.168.0.1\FolderName\MyData.accDB

    And the same is if you hit browse in above.  So, often IP is better for the reasons noted. But two network connections still might cause issues - it just that IP tends to limit the issues somewhat.

    Regards,

    Albert D. Kallal (Access MVP 2003-2017)
    Edmonton, Alberta Canada



    Sunday, September 6, 2020 8:41 PM