locked
Load report failed. RRS feed

  • Question

  • User-2105936398 posted

    Hi,

    i am trying to load the report but i am having some problem. the error is : Load Report failed.

      Dim reportPath As String = Server.MapPath("..\Authenticated\Manager\Reports\Tenant Reports\Cr_master.rpt")
     masterReport.Load(reportPath)

    here is the physical path of the report: E:\Projects\Ongoing Projects\Hostel_Web_Application\Authenticated\Manager\Reports\Tenant Reports\Cr_master.rpt

    Thursday, November 10, 2011 12:00 PM

Answers

  • User1196771204 posted

    hi djamajo,

    there are few things you need to make sure in order to run Crystal Report 2010 properly on your system:

    1. Please make sure that the crystal report version installed on the system matches the one you used on your code
    2. Please make sure that the correct crystal report assemblies are used on your web.config
    3. Please make sure that the application pool where your reports run is set to LOCAL SERVICE permission
    4. Please make sure that FULL TRUST permission is enabled on your operating folder
    5. Please make sure you copy the aspnet_client and crystalreportviewer folders to your operating folder.

    If you follow all the required steps above, your crystal report should work fine. If you need a host that supports Crystal Report 2010, you can consider asphostcentral.com. Please mark this response as an "answer" if it helps you.

    Thanks heaps 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, November 17, 2011 2:34 AM

All replies

  • User197322208 posted
    try
    Server.MapPath("~/Authenticated/Manager/Reports/Tenant Reports/Cr_master.rpt")
    Thursday, November 10, 2011 12:29 PM
  • User1196771204 posted

    hi djamajo

    Have you resolved this issue? May I please know where did you host your crystal report? Is that on a shared server or your local PC? Have you made sure the Crystal Report version installed on the system matches the one you used on your code?

    :) 

    Friday, November 11, 2011 1:02 AM
  • User-2105936398 posted

    I tried with (~/...) but it's still the same error.

    I am trying to load it from my local machine.

    I am using CR for VS 2010.

    Thank you.

    Friday, November 11, 2011 4:32 AM
  • User465276454 posted

    If the report  loding fails, main problem is only the path setting afetr hosting.it will work in local bt ot worked in server. set the path like ~/ or ../ .

    Thanks,

    Phani

    kari.phani@gmail.com

    Saturday, November 12, 2011 11:48 AM
  • User-2105936398 posted

    ok,but it's not working on my local system.

    Monday, November 14, 2011 3:05 AM
  • User1196771204 posted

    hi djamajo,

    there are few things you need to make sure in order to run Crystal Report 2010 properly on your system:

    1. Please make sure that the crystal report version installed on the system matches the one you used on your code
    2. Please make sure that the correct crystal report assemblies are used on your web.config
    3. Please make sure that the application pool where your reports run is set to LOCAL SERVICE permission
    4. Please make sure that FULL TRUST permission is enabled on your operating folder
    5. Please make sure you copy the aspnet_client and crystalreportviewer folders to your operating folder.

    If you follow all the required steps above, your crystal report should work fine. If you need a host that supports Crystal Report 2010, you can consider asphostcentral.com. Please mark this response as an "answer" if it helps you.

    Thanks heaps 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, November 17, 2011 2:34 AM