none
SQL Server 2012 Database engine failed to install everytime RRS feed

  • Question

  • Hi,

    I am trying to install SQL Server 2012 -64 bit in our dev server running Windows Server 2012. Everytime, Database engine fails to install. I've checked the event logs it shows.

    Operating system error 2(The system cannot find the file specified.) occurred while creating or opening file 'e:\sql11_main_t.obj.x86release\sql\mkmastr\databases\objfre\i386\modellog.ldf'. Diagnose and correct the operating system error, and retry the operation.

    I followed the link- https://serverfault.com/questions/447808/sql-server-express-service-is-not-starting to resolve the issue. I opened command prompt and run the command - NET START MSSQL$SQLEXPRESS /f /T3608

    But it throws the error - The service name is invalid.

    Has anyone gone through this issue. Please suggest a solution for this issue.

    Thanks,


    Kunal

    Saturday, June 13, 2020 4:17 PM

All replies

  • In C:\Program Files\Microsoft SQL Server\110\Setup Bootstrap, there is a folder for each instllation attempt. In each such folder there is a file Detail.txt. I think we need to sse this file to understand more exactly what is happening. The file is to big to post here. Upload it somewhere (Dropbox, OneDrive etc) and share the link here.


    Erland Sommarskog, SQL Server MVP, esquel@sommarskog.se

    Saturday, June 13, 2020 8:52 PM
  • SQL SERVER - How to Restore Corrupted Model Database from Backup? model-01

    take model .ldf from working server. and paste there and start mssql as in 

    1. Start SQL with trace flag 3608. To do that Use this from command prompt: sqlservr.exe -T3608
    2. Start SQL Server via command prompt using sqlservr.exe -c –m

    share your error log and refer following link

    https://blog.sqlauthority.com/2015/09/26/sql-server-how-to-restore-corrupted-model-database-from-backup/


    https://social.technet.microsoft.com/wiki/contents/articles/37872.sql-server-installation-on-centos-linux.aspx

    Sunday, June 14, 2020 1:06 AM
  • Hello Kunal,


    So  uninstall and reinstall once again, but this time you have to  change the service accounts during setup, SQL SEVER service, all from the default NT Service\<something> to the built-in NTAUTHORITY\LOCAL SERVICE or NTAUTHORITY\NETWORK SERVICE. Having changed these during setup, everything will work..

    Found somewhere in google. Give it a try..!!


    Ram

    Sunday, June 14, 2020 4:06 AM
  • Hi

    1-First check controll panel whether some componemt of sql server is exist or not
    2- before uninstall look up some guidline 
    https://stackoverflow.com/questions/36377259/how-to-completely-uninstall-sql-server-2012

    3- If one instant is installed that is in the default instance .Again can installed as named instance
    Sunday, June 14, 2020 11:09 AM
  • Hi Kunal,

    Did you face the issue when you were installing the SQL Server 2012 or starting the SQL Server service after installation?

    If failed with installation, please provide some key error details in C:\Program Files\Microsoft SQL Server\110\Setup Bootstrap\log, Summary folder or detail.txt in the installation date folder.

    If failed with starting service, you could try with below command:

      NET START MSSQLSERVER /f /T3608 --default instance

      NET START MSSQL$ instancename /f /T3608  --named instance

    Express is one edition of SQL Server. The other editions are Enterprise,Standard and Developer.

    Best regards,

    Melissa

    -------------------------------------------

    MSDN Community Support

    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com


    Monday, June 15, 2020 6:55 AM
  • Hi Kunal,

    Could you please let us know if any update about the error?

    If you have fixed, please let us know the solution and mark it as answer.

    If not, please validated all the solutions provided.

    Best regards,

    Melissa

    -------------------------------------------

    MSDN Community Support

    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, June 22, 2020 1:26 AM
  • Hi All,

    The issue is not yet resolved. Is this the Operating System issue?

    Thanks,


    Kunal

    Tuesday, June 30, 2020 1:14 PM
  • Hi Kunal,

    Maybe you could ask professional engineers for help, and they will deal with your problem separately and confidentially:

    https://support.microsoft.com/en-us/assistedsupportproducts

    Best regards,

    Melissa

    -------------------------------------------

    MSDN Community Support

    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Wednesday, July 1, 2020 6:30 AM