none
The HTTP request is unauthorized with client authentication scheme 'Ntlm'. The authentication header received from the server was 'NTLM'. RRS feed

  • Question

  • Hi guys,

    I came across this problem when writing code in the event handler for Project Server 2010. I'm not sure what happened, does anybody why is this issue?

    Thursday, June 2, 2011 1:56 AM

Answers

    1. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    Examples: www.daenet.eu, currencyserver.de

    Method 2: Disable the loopback check

    Follow these steps:

    In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    Create the value DisableLoopbackCheck and enter 1 in the Value data box, and then click OK.

    Do not forget to restart machine!


    IT Worker
    Saturday, September 24, 2011 2:10 PM

All replies

  • Does the user you're using for your PSI calls have the appropriate PS permissions? Try with an admin user. Also see this link, someone had the same problem... http://fluentps.codeplex.com/discussions/234339/
    Thursday, June 2, 2011 4:05 AM
  • As far as I'm concerned, the event handler in PSI 2010 runs under the account of the Event Services. Since the Event Service account is an admin user, so I think it should work.

    Any idea?

    Thursday, June 2, 2011 4:12 AM
  • Not necessarily, you could use different credentials for the PSI web services. It runs under the Eventing Service account only if you use DefaultCredentials...

    Might help if you post a code snippet :)

    Thursday, June 2, 2011 4:33 AM
  • I see.

    I'm going to try it later.

    Thanks,

    Thursday, June 2, 2011 4:58 AM
    1. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    Examples: www.daenet.eu, currencyserver.de

    Method 2: Disable the loopback check

    Follow these steps:

    In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    Create the value DisableLoopbackCheck and enter 1 in the Value data box, and then click OK.

    Do not forget to restart machine!


    IT Worker
    Saturday, September 24, 2011 2:10 PM
  • PCCAI has it, at least in my case configuring the Loopback fixed this for me in the past.

    However I prefer the first option as per: http://support.microsoft.com/kb/896861, as it saves a reboot and is more secure.

     

    Regards,


    Martin Laukkanen (Project Server Blog - http://www.nearbaseline.com/blog)
    Wednesday, September 28, 2011 12:47 AM