locked
The "WindowsLocalDebugger" rule is missing the "LocalGPUDebuggerTargetType" property RRS feed

  • Question

  • I've ported one of our solutions, from VS2010 (and Windows 7.0) to VS11 (and Windows 8.0). When I try to launch the executable from visual studio, I get the above error.

    I get the error regardless of whether i launch with debugging enabled or not and I'm not quite sure what to make of it. Anyone have a clue of where I should start looking?

    Tuesday, February 28, 2012 11:07 PM

All replies

  • I'm having the same issue.

    -- Ralph

    • Proposed as answer by bbusacker Friday, March 16, 2012 4:27 PM
    • Unproposed as answer by bbusacker Friday, March 16, 2012 4:28 PM
    Wednesday, February 29, 2012 11:26 PM
  • Occasionally, I seem to get the following error instead:

    Unable to cast object of type 'Microsoft.VisualStudio.Project.ConfiguredProjectCache`1[Microsoft.VisualStudio.Project.Immutables.ImmutableHashMap`2[System.String,System.Threading.Tasks.Task`1[Microsoft.VisualStudio.Project.PropertyPages.PropertyPagesCatalog]]]' to type 'Microsoft.VisualStudio.Project.ConfiguredProjectCache`1[Microsoft.VisualStudio.Project.Immutables.ImmutableHashMap`2[System.String,Microsoft.VisualStudio.Project.PropertyPages.PropertyPagesCatalog]]'

    Wednesday, February 29, 2012 11:26 PM
  • I am also having this issue and see both of the messages you've posted.

    Given it mentions GPU, perhaps its related to the GPU we have? I've got a Radeon 7970 which has no official non-RC drivers yet - maybe the card is not supported?

    Thursday, March 1, 2012 12:05 AM
  • I've got an ATI 4650. DX10 but no DX 11 support.

    I'm working on a C++ project, I haven't tried one from scratch yet.


    -- Ralph

    Thursday, March 1, 2012 12:37 AM
  • File/New Project works just fine for trivial C# and C++ apps1, so it's something about the specific project files, I'm guessing.


    -- Ralph

    Thursday, March 1, 2012 12:48 AM
  • Yeah same for me as well, new projects work. My (broken in VS11) project files are hand rolled so it could be something needs adding in now (although after a quick scan and nothing stands out). My projects are also C++ (unmanaged). 
    Thursday, March 1, 2012 1:12 AM
  • Same here. New C++ projects work. Existing ones dont.
    Thursday, March 1, 2012 1:57 AM
  • I can reproduce this problem with VS11 Customer Preview released today.

    I have reported the problem to Microsoft in connect website: https://connect.microsoft.com/VisualStudio/feedback/details/727404/vs11-error-message-when-running-c-debuggee

    Feel free to vote for it and/or add a comment to the report description if you want this problem solved.

    Thursday, March 1, 2012 2:15 AM
  • I reproduce this problem with new C++ projects (MFC or Win32) on my box.

    How do you manage to create a working C++ project and build it?

    Don't you set Platform toolset to WindowsSDK7.1 in project/setting/general?

    Thursday, March 1, 2012 2:18 AM
  • I found one fix, although I don't like it. I copied the project and solution files and used the 'Upgrade VC Projects' option. Once I did that, I was able to build and debug my project. It means that the backwards compatibility doesn't work for my project.

    -- Ralph

    Thursday, March 1, 2012 2:23 AM
  • I did the most trivial C++ project, I created a new Console project with the VS11 beta. That compiles and runs fine on my box.

    -- Ralph

    Thursday, March 1, 2012 2:25 AM
  • I have the same problem. Just compiles with VS11 mode, but I want to stay compatible with VS10
    Thursday, March 1, 2012 1:40 PM
  • I've the same problem but I've found a trick to workaround this problem until MS fixes it.

    The trick is to create in your solution a makefile project, set its debugging options to point to the real executable you want to debug (you may also need to fill other field, like the working folder) and set it as the startup project.

    If you have multiple startup projects, you can use a batch file to run them all or create multiple makefile projects.

    Hope this helps


    Ale

    Thursday, March 1, 2012 3:08 PM
  • I have the same problem. I've tried to disable 'Merge Environment' option (Project properties -> Debugging) and it works.
    Thursday, March 1, 2012 5:03 PM
  • I've managed to fix this in a constructive way.

    Put this

    <PropertyGroup Condition="'$(VisualStudioVersion)'=='11.0'" Label="Configuration">
    <PlatformToolset>v110</PlatformToolset>
    </PropertyGroup>

    between

    <Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />

    and

    <Import Project="$(VCTargetsPath)\Microsoft.Cpp.props" />

    in your project files.

    This should keep it backwards compatible and use the new toolchain when running VS11. * Probably needs fixing for service packs though.


    • Proposed as answer by icStatic Thursday, March 1, 2012 11:58 PM
    Thursday, March 1, 2012 11:58 PM
  • But you will need to make these changes for all projects in your solutions. Otherwise you will receive something like:

    error LNK2038: mismatch detected for '_MSC_VER': value '1600' doesn't match value '1700' in ...

    in fact, it is very strange MS releases product which doesn't work in very common scenario :(

    Friday, March 2, 2012 12:11 AM
  • I solved the problem of making the change to all solutions long ago by factoring out the 'common' parts of my MSBuild project files into a 'Default' file. So I'm lucky it was only a one line change. Admittedly for most people that's a right pain though...
    Friday, March 2, 2012 1:15 AM
  • You can also change that setting under projects/property/general.

    It's safer than upgrading, I guess.

    Unfortunately, it doesn't work 100%. VC10 doesn't recognize the Platform Toolset of 11 and VC11 won't run a program built with Platform Toolset 10. If you're switching between IDEs, you will still have to change the platform toolset each time you change versions. I created a new C++ Console project and told it to use the VC10 Toolset and it won't run.


    -- Ralph

    Friday, March 2, 2012 3:46 AM
  • The problem of changing the toolset as icStatic proposed, is that if you compile under Visual Studio 11 it will compile as VC11 and not as VC10. This could not work in some situations (third party libraries not compiled for VC11) and you need to be aware of that, especially if you are planning to redistribute your program (if you compile with VS11 beta, you can redistribute your program only if it uses static runtime linking)

    Ale

    Friday, March 2, 2012 8:07 AM
  • I have the same problem. I've tried to disable 'Merge Environment' option (Project properties -> Debugging) and it works.
    I forgot about one step. You should also change 'Debugger Type' from 'Auto' to 'Mixed' or 'Native'. In that case you will normally use VS 2010 environment. And no modification of project files will be performed.


    • Proposed as answer by Igor Lifanov Friday, March 2, 2012 11:12 AM
    • Edited by Igor Lifanov Friday, March 2, 2012 3:57 PM
    Friday, March 2, 2012 11:12 AM
  • I've managed to fix this in a constructive way.

    Put this

    <PropertyGroup Condition="'$(VisualStudioVersion)'=='11.0'" Label="Configuration">
    <PlatformToolset>v110</PlatformToolset>
    </PropertyGroup>

    between

    <Import Project="$(VCTargetsPath)\Microsoft.Cpp.Default.props" />

    and

    <Import Project="$(VCTargetsPath)\Microsoft.Cpp.props" />

    in your project files.

    This should keep it backwards compatible and use the new toolchain when running VS11. * Probably needs fixing for service packs though.



    In that case you simply change environment of your projects. It can be done automatically by VS 11 beta. You need to simply delete hidden files near your solution: *.sdf, *.opensdf, *.suo (and you may also delete ipch folder). After that open solution in VS 11 beta, it will propose you to change environment of your projects to use new tools.
    Friday, March 2, 2012 11:15 AM
  • That did not work for me.

    This can be replicated very easily by creating a new Vicual Studio C++ Console project and seeting the Toolset to VC10. I tried changing the merge environment settings and debugger type and it still returns the same error.


    -- Ralph

    Friday, March 2, 2012 4:00 PM
  • I get the same error even before I upgrade my solution, across multiple systems:

    Systems:

    - Windows 7 Professional x64 all /Microsoft/ updates applied,
    - Visual Studio 2010 Professional (not sure how to tell if it's the x64 or x86 version),
    - Visual Studio 2011 Professional Beta x86 (according to the ISO, it looks like the x64 installation tho),

    Project: No CLR, C++ and C only, 12 projects, many of which still have their legacy .vcproj files lying around, ~4.5 million total lines of code.

    Target: Debug / Win32

    Replication:

    1. Prior to 2011 install, perform clean build all with 2010 to verify project build.
    2. copy $(SolutionDir) -> $(SolutionDir)-2011
    3. Install 2011 Professional and reboot as many times as required to complete install
      (Having to reboot my workstation 3 times to install a compiler brought tears to my eyes)
    4. Load Visual Studio 2011
    5. Open .sln from $(SolutionDir)-2011
    6. Decline to upgrade
    7. Build -> "Rebuild $(ProjectName) (Visual Studio 2010)"
    8. Debug > Start Debugging
    9. ERROR
    10. Build -> "Rebuild Solution"
    11. Debug -> Start Debugging
    12. ERROR

    Also, installing VS2011 causes VS2010 to fail to load the /original/ solution, for me:

    E:\pn\baseline\Tools\TestTeul\TestTeul.vcxproj : error  : MSBuild does not contain a value for the "VCTargetsPath" property.

    

    Saturday, March 3, 2012 7:15 PM
  • >Also, installing VS2011 causes VS2010 to fail to load the /original/ solution, for me:

    >E:\pn\baseline\Tools\TestTeul\TestTeul.vcxproj : error  : MSBuild does not contain a value for the "VCTargetsPath" property

    I've had this problem. It happened because I uninstalled VS11 Deeveloper Preview. I've read this problem happens when you uninstall the previous version of VS11.

    Solution is to reinstall SP1 for VS2010...

    Saturday, March 3, 2012 8:55 PM
  • Thanks; gonna try a "Repair" first, then I'll give a reinstall a shot when that fails :)

    Saturday, March 3, 2012 8:57 PM
  • I've the same problem but I've found a trick to workaround this problem until MS fixes it.

    The trick is to create in your solution a makefile project, set its debugging options to point to the real executable you want to debug (you may also need to fill other field, like the working folder) and set it as the startup project.

    If you have multiple startup projects, you can use a batch file to run them all or create multiple makefile projects.

    Hope this helps


    Ale

    I've got a mammoth mixed C++/CLI project full of legacy code that I still unfortunately have to build against the v90 toolset.  Downloaded the 11 beta; everything compiled OK, but I couldn't debug due to this error and similar every time I tried starting.  This workaround did the trick for me, for now, though I would also note I had to explicitly configure the makefile project debugging options to use debugger type of Mixed instead of Auto to be able to debug any C++/CLI code.

    Though I will also note that debugging said C++/CLI code seems to perform horribly...especially if I try examining any variables.  I don't know if that's due to it being started by this proxy makefile project, or if that's just a "feature" of 11 in general...
    • Edited by microhof Wednesday, March 7, 2012 5:47 PM
    Wednesday, March 7, 2012 5:32 PM
  • Hi,

    I am facing the same issue when I am trying to create a FEFLOW project using MS visual 2010 expess.. while creating the new project at the end when i click on finish, it gives below error

    The "WindowsLocalDebugger" rule is missing  from the project.

    If anyone knows what is the workaround for this, please let me know.

    Thanks in advance.

    -Madhura S Joshi

    Tuesday, March 20, 2012 2:03 PM
  • Hurray! This bug has been fixed by Microsoft.

    A patch has just been released for VS11 beta : http://support.microsoft.com/kb/2677574

    Download of update is automatic. Just run VS11 : http://blogs.msdn.com/b/visualstudio/archive/2012/04/06/improving-how-we-update-visual-studio.aspx

    Wednesday, April 11, 2012 1:42 AM