locked
IIS 8.5 New Application Failed RRS feed

  • Question

  • User-89519501 posted

    We recently upgraded an IIS 7.5 server to IIS 8.5 and after upgrade all classic ASP sites are not working. The server hosts numerous sites and applications including PHP, .net 2.x, 4.x etc and it seems most everything except classic ASP works now after a little cleanup. I've tried uninstalling and reinstalling the ASP feature, creating a new clean app and app pool with very limited handlers enabled as well as changing some of the ASP settings and inheritance as described in forums where this used to be a problem in earlier versions of IIS. So far nothing has worked. Freb, event logging, IIS logs and procmon on asp.dll have all failed to give me any insights into where the problems might exist. Unfortunately this is an intranet server with numerous sites and 100's of applications that has gone through multiple generations of upgrades and admins. While I am trying to go through the process of coordinating clean migrations to a new server it takes months to get just a few sites done. I think at this point I'm overlooking something obvious, debugging IIS problems has never been this elusive before.

    Friday, June 15, 2018 8:20 PM

All replies

  • User-2064283741 posted

    What do you mean it doesn't work? error pages, etc?

    Is this for all asp content/sites or just some?

    Does a "hello world" asp page work?

    What does failed request tracing say?

    Saturday, June 16, 2018 12:20 AM
  • User-89519501 posted

    No ASP works at all. Even simple hello world. Everything returns an HTTP/1.1 New Application Failed with event ID 9. Freb doesn't show anything more either.

    Saturday, June 16, 2018 11:31 PM
  • User121216299 posted

    Hi brumage_d,

    If we talk about error,"HTTP/1.1 New Application Failed" then below can be the reason to cause this error.

    The IUSR account is a domain account. However, this account is not being authenticated correctly against a domain controller.

    Below are the steps to solve this issue.

    1. Open the properties of the Default Web Site and choose Directory Security.
    2. Click the Edit button for Authentication.
    3. Click the Edit button for Anonymous and edit the account listed to read "Domain-name\Anonymous."
    4. Disable Password Synchronization.
    5. Manually shut down the MMC to ensure proper writing to the metabase.
    6. Go to a command prompt and issue "net stop iisadmin /y."
    7. At the command prompt, issue "net start w3svc."

    Reference:

    Err Msg: HTTP/1.1 New application failed

    Regards

    Deepak

    Monday, June 18, 2018 2:20 AM
  • User-89519501 posted

    Hi Deepak, Thank you, yes, I saw these threads in other forums but our sites don't use Anon Auth, everything is Windows authentication. We have custom service accounts for the app pools, but this is also true of all the other apps as well and PHP, .Net 2, .Net 4 etc all work fine with this config. I did create a test app and try in that to change the authentication from the custom account to Network Service and App Pool identity, neither of those resolved the issue or changed the error.

    Tuesday, June 19, 2018 2:39 PM
  • User121216299 posted

    Hi brumage_d,

    Temporary, Try to remove those Classic ASP sites and try to reinstall the IIS.

    Make sure all the latest windows related updates are installed and then try to install ASP in IIS.

    set your ASP sites in IIS and try to reproduce the issue to check whether issue get solved or exist.

    Try to make a test on your side and let us know about the result.

    We will try to provide further suggestions, If needed.

    Regards

    Deepak 

    Wednesday, June 20, 2018 5:38 AM
  • User-89519501 posted

    Hi,

    I was afraid we'd come to this suggestion. Unfortunately this server hosts over 20 intranet sites and several hundred applications as well as numerous virtual directories with .Net 2, .Net 4, PHP and other things all working except classic ASP. Uninstalling and reinstalling IIS will be a very time consuming and unaccepted approach for the customers whose sites are not impacted. The in place upgrade was attempted to avoid trying to build a clean server like I usually do for other sites due to the number of sites and apps to migrate, especially knowing some of the code base is old and not well documented. 

    Wednesday, June 20, 2018 2:48 PM
  • User121216299 posted

    Hi brumage_d,

    Did you try to check for any pending Windows update?

    If not then try to check for any pending update and if available then install it.

    Check whether it makes any difference or not.

    Regards

    Deepak

    Monday, June 25, 2018 8:43 AM