locked
WDS 2.6.5 RRS feed

  • Question

  • Congrats on the release of WDS 2.6.5.

    I have some questions before I start digging into it.

    Background - I have a product due for release this summer that uses WDS. Currently it uses the MSN Toolbar 2.05 version (beta, I think, as in it was always beta). It works pretty well and I am happy with it.

    - Is the new 2.6.5 and the old WDS 2.05 compatible from an API stand-point, as in, do I need to reference a new WDSQuery.dll? My current WDSQuery shows file version 2.5.0.0.

    - If I need a new WDSQuery.dll, where do I get it from?

    - Is there a list of breaking changes (i.e. the use of the URL field in the return results). I realize that this is still early days, so I can expect a delay for full SDK docs, but even early info would be great.

    - Can I use this forum to get info about the above?

     

     

    Tuesday, April 18, 2006 1:20 PM

Answers

  • Hi David,

    Given some of your more recent posts, I'm guessing you have already found your answer.  Still, here is one from me :-)

    You will need to reference a new .dll with 2.6.5.  Once you've installed 2.6.5 the .dll can be located in C:\program files\windows desktop search\WDSQuery.dll

    Unfortunately, there isn't a document that clearly notes the API differences between 2.5 and 2.6.5.  On the bright side, an SDK for 2.6.5 is due out this summer.

    Paul Nystrom - MSFT

    Wednesday, May 24, 2006 11:59 PM

All replies

  • Hi David,

    Working this for you. 

    Yes - you can use this forum to get answers for these questions - just the right place actually.  To potentially reduce the time it might take to get those answers I would  suggest that you give the forum below a try as well:

    http://forums.microsoft.com/MSDN/ShowForum.aspx?ForumID=111&SiteID=1

    Hope this helps and stay tuned.

    Bill Connors

    Program Manager, Windows Desktop Search - Communities

    Friday, April 21, 2006 10:59 PM
  • Hi David,

    Given some of your more recent posts, I'm guessing you have already found your answer.  Still, here is one from me :-)

    You will need to reference a new .dll with 2.6.5.  Once you've installed 2.6.5 the .dll can be located in C:\program files\windows desktop search\WDSQuery.dll

    Unfortunately, there isn't a document that clearly notes the API differences between 2.5 and 2.6.5.  On the bright side, an SDK for 2.6.5 is due out this summer.

    Paul Nystrom - MSFT

    Wednesday, May 24, 2006 11:59 PM