none
[Solved] What is the basic catalog item selection for LCD Display of 7 inch for AM335x BSP? RRS feed

  • Question

  • What should be the minimum Catalog Items selection in WINCE 7.0 for 7inch LCD Display. I am just revolving around this from the past one and half month but unable to solve the problem....

    I made change in the bsp_lcdc.h as

    typedef enum BSP_LCDC_RES 
    {
        LCD_014_640x480 = 0,
        LCD_017_800x480,// This is my lcd entry
        LCD_017_104S_800x600,
    	HITACHI_TX14_320x240,
    	EMERGING_ETM07_800x480,
        Headless_800x600,
    } BSP_LCDC_RES;
    
    
    #define BSP_LCD_DEFAULT_RES LCD_017_800x480

    and lcd_vga.c as

    {
            /* PrimeView 7" LCD Panel LCD-017 */
            LCDC_PANEL_TFT | LCDC_INV_VSYNC | LCDC_INV_HSYNC 
            | LCDC_HSVS_CONTROL | LCDC_INV_PIX_CLOCK, // config
            DISPC_PIXELFORMAT_RGB32,    // bpp
            800,           // x_res 
            480,           // y_res
            30000000,      // pixel_clock
            128,           // hsw 
            42,            // hfp
            86,            // hbp
            4,             // vsw
            1,             // vfb
            23,            // vbp
            255,           // acb (acbias)
            0,             // mono_8bit_mode
            0,             // tft_alt_mode
            COLOR_ACTIVE,  // panel_shade
            LCDC_panel_PrimeView_init  // init
        }


    and in catalog Items

    under my BSP

    Display - Backlight driver, LCDC Display driver both are selected,

    Kernel Features -  Internal Watchdog, Persistent Hive Registery Storage both are not selected

    Under Core OS-Device Driver

    Backlight Driver - is selected

    Display - ATI Rage XL Expert 98 , Multi monitor support, NULL(stub) - no one is selected

    What about shell, graphics and media and File Systems and Data Store

    For more details please visit the following links 

    http://social.msdn.microsoft.com/Forums/en-US/0e6ef102-d86a-4577-a178-e7c35e730187/step-by-step-booting-process-for-am335x?forum=winembplatdev#bd767c55-d1df-41ca-bea8-c3e505405e17

    http://e2e.ti.com/support/embedded/wince/f/353/t/312265.aspx

    • Edited by salathia Monday, February 3, 2014 4:00 AM
    Monday, January 6, 2014 10:25 AM

All replies

  • Bruce has suggested you in the previous post of yours to check if you have enabled "Shell" or not.

    If shell is not enabled enable it and build and test.

    I have replied you that may be the display resolution is not proper because for me the display appears to be improper.

    Kindly post the log message if you are getting error in booting.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Tuesday, January 7, 2014 7:42 AM
  • Obviously I have to enable shell otherwise i wont be interact with the interface......  And, Now I am not getting any error message during booting
    • Edited by salathia Tuesday, January 7, 2014 9:18 AM
    Tuesday, January 7, 2014 9:17 AM
  • Can you describe properly what is the problem that you are facing now ?

    And did you tried with the resolution change, if the display is still not working for you ?

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Tuesday, January 7, 2014 10:11 AM
  • After my first post in TI fourm. I have solved the issue up to some extend. Now after boot loader four colors. The Kernel is booting and I have enabled one USB port.. Its led is glowing on the board and i have connected one mouse with that USB.. Mouse is getting power from USB. On the other hand on LCD screen I have one msg Fully press and briefly hold stylus on the center of the screen. Repeat as the target moves around the screen. Press the Esc key to cancel.  I connected the keyboard to cancel this but it was not working fine. and I also press the + symbol many times on the screen. It moved to all corners but after that it retain its original position in the center and after pressing it repeat the previous statement like four corner...........From resolution point of view i have created one entry in the structure for 3.5 inch LCD. so for 3.5 inch  , the resolution is fine and also fine with 7 inch.... but the problem is same for both....
    • Edited by salathia Tuesday, January 7, 2014 10:50 AM
    Tuesday, January 7, 2014 10:49 AM
  • It is not obvious to me that you have in fact included the Explorer Shell in your OS.  So, what exactly did you include?

    Bruce Eitman (eMVP)
    Senior Engineer
    Bruce.Eitman AT Eurotech DOT com
    My BLOG http://geekswithblogs.net/bruceeitman

    Eurotech Inc.
    www.Eurotech.com

    Tuesday, January 7, 2014 1:26 PM
    Moderator
  • Under Shell I have included---

    SYSGEN_AYGSHELL

    SYSGEN_STANDARDSHELL

    IMG_SCREEN_MEDIUM

    Wednesday, January 8, 2014 4:40 AM
  • Now, display is coming but the problem is that when i press esc key after attaching the keyboard or click after attaching mouse, the screen turns to grey.........................
    Wednesday, January 8, 2014 11:24 AM
  • You are not telling us how your earlier problem was resolved and asking a new question (Without much explanation and debug logs)

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Wednesday, January 8, 2014 11:45 AM
  • It was resolved after adding Raster Font Support and V1 Font Capability...... Now, after boot loader four colors square, I am getting a touch calibration but touching on the screen on particular symbol for 5 times at different coordinates, the plus symbol again comes in the center of the screen... It means my desktop is not loading after touching calibration...... And @Misbah you are talking about which logs..........

    Ohhhh debug logs... I am not using debug logs because after enabling that feature my image size increase 130 MB. So, I am not using debug logs now....... but previously i used once and i have observed some modules were loaded with .dll extension but am33x_display.dll was not loaded......
    • Edited by salathia Thursday, January 9, 2014 4:19 AM
    Thursday, January 9, 2014 4:14 AM
  • If calibration is not completing it means that touch is not giving the correct coordinates.

    Try to print the touch coordinates when you touch and see if the coordinates are correct when you touch.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    Thursday, January 9, 2014 5:15 AM
  • When it tries to calibrate again this usually indicates that your touchpoints were not properly oriented for calibration. Try using a stylus, not your finger, to tap the targets and take extreme care to hit each one dead-center. If it still doesn't work then something is probably wrong in the hardware initialization causing touch to sort of work but not position correctly.

    Paul T.

    Wednesday, January 15, 2014 1:15 AM
  • Hello, I am back again. Sorry I was not well that why unable to reply. I want to share more info about this problem. Now the display is coming properly on 7 inch as well as 3.5 inch without touch. But it hangs after some seconds. And one more thing is that the same BSP with the same catalog Items is working on different board. I am using RANA board and different board is COSMIC board. The differencve b/w these two are the RAM size.

                     RANA                                               COSMIC

    1.        128 MB RAM                               512 MB RAM

    I am using COSMIC BSP for RANA board. SO, I think so certain services are not working properly thats why display hangs after some seconds.  If my thought is right then please provide me the way to solve the problem.

    Thursday, January 30, 2014 3:43 AM
  • Since the memory configuration is different for different board and you are using the same BSP the problem should come.

    To solve it you need to reconfigure your memory accordingly.

    Changes should be done in config.bib file for RAM related.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    • Marked as answer by salathia Wednesday, March 5, 2014 4:06 AM
    • Unmarked as answer by salathia Friday, April 4, 2014 6:26 AM
    Thursday, January 30, 2014 6:14 AM
  • Cosmic board RAM is 512 MB and its configuration is as:-

    1.      nk  - 98MB

    2.     RAM - 110MB

    3.     RAM disk - 96 MB

    4.    DISPLAY  -  32 MB

    RANA board RAM is 128 MB and its configuration is as:-

    1.      nk  - 98MB

    2.     RAM - 110MB

    3.     RAM disk - 96 MB

    4.    DISPLAY  -  32 MB

    And my nk.bin size for RANA board is max 85 MB. I am facing the problem with RANA Board. So, I think so it should not create problem. What's your suggestion on this configuration?


    • Edited by salathia Thursday, January 30, 2014 9:37 AM
    Thursday, January 30, 2014 9:37 AM
  • Your NK, RAM disk, display and free ram all should fit under 128MB

    How do believe that it should not create problem ??

    Remap this and it will solve your problem.

    --- Misbah


    Senior Design Engineer T.E.S Electroni Solutions (Bangalore-India) www.tes-dst.com email-misbah.khan@tes-dst.com

    • Proposed as answer by Misbah Khan Friday, January 31, 2014 5:40 AM
    • Marked as answer by salathia Wednesday, March 5, 2014 4:06 AM
    • Unmarked as answer by salathia Friday, April 4, 2014 6:27 AM
    Thursday, January 30, 2014 10:23 AM
  • Sure I will do this....

    Thursday, January 30, 2014 11:26 AM
  • @Misbah

     Now problem Solved. Touch and display is also working properly.

    Thanks for your valuable support......

    Monday, February 3, 2014 4:01 AM