locked
visual studio stops responding after change main layout RRS feed

  • Question

  • User102853 posted

    Hi, my visual studio stops responding after changing layout in android project

    Debug is on real device, xamarin is latest, visual studio is 2015 And then i must restart complete pc to start working again

    any idea?

    Sunday, October 30, 2016 10:37 PM

Answers

All replies

  • User218392 posted

    what is that after changing layout in android project you are telling i didn't get which layout you have changed?

    still it's depend upon the RAM how much your PC have if you have 16GB RAM your system work smootly, however 8GB RAM also working fine but sometime visual studio stops responding these types of problem comes. :)

    Monday, October 31, 2016 5:47 AM
  • User228975 posted

    @Arvindraja said: what is that after changing layout in android project you are telling i didn't get which layout you have changed?

    still it's depend upon the RAM how much your PC have if you have 16GB RAM your system work smootly, however 8GB RAM also working fine but sometime visual studio stops responding these types of problem comes. :)

    Try one up two or more .axml layout file in Visual Studio 2015. Now Switch between the Designer and Source of one of the layout file then move to the next one, do the same. You will notice that the Designer will load forever and the only way to get it to work again is to close visual Studio and open again.

    This starts happening after Xamarin 4.2 update.

    Monday, October 31, 2016 6:45 AM
  • User218392 posted

    sometime it happens but every time happening means some problem is there if taking time to parse xaml The solution may be is to set the same version for "Target version" and "Minimum version from properties and try to run VS2015 as administration hope it help you :)

    Monday, October 31, 2016 7:09 AM
  • User228975 posted

    @Arvindraja said: sometime it happens but every time happening means some problem is there if taking time to parse xaml The solution may be is to set the same version for "Target version" and "Minimum version from properties and try to run VS2015 as administration hope it help you :)

    It is all the time happening and this is repeatable across multiple machine. FYI, we are compiling the same project and the settings are all identical. Target Android Version = "Use Compile Using SDK Version"
    Compile using Android Version = " Use Latest Platform (Android 7) " Minimum Android to Target=" Android 5.0". I am pretty sure it is a big bad bug in the Designer.

    On machine that do not have the Xamarin 4.2 update, there is no such issue.

    Monday, October 31, 2016 7:45 AM
    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, October 31, 2016 8:00 AM