locked
Cannot build after having updated to Xamarin Cycle 9 RRS feed

  • Question

  • User138822 posted

    Each time I debug/deploy to my device, my app initially begins launch then ends with 'app has terminated'. I have been dead in the water for two days now. The error I am getting is the following:

    Severity Code Description Project File Line Suppression State Error error MT1006: Could not install the application '/Users/JP/Library/Caches/Xamarin/mtbs/builds/LOS.iOS/2e3f7439fde993698da6c6580c5244c4/bin/iPhone/Debug/Lendforce.app' on the device 'James's iPhone': AMDeviceSecureInstallApplicationBundle returned: 0xe80000be (kAMDMismatchedApplicationIdentifierEntitlementError). 0

    I have updated to the latest version of Java JDK and have updated Xamarin to point to the correct directory.

    Also, I am getting the following warnings:

    (I do not use android so I am unsure about this warning, also am unsure where to download the SDK, as I only see SDK command line tools on the Android website) Severity Code Description Project File Line Suppression State Warning An unexpected error occurred trying to initialize Android Designer. Please verify the Android SDK path and the Java Development Kit path on Tools->Options->Xamarin->Android Settings menu. Please see the logs for more details. 0

    (I tried editting my csproj file but did not see this key available) Severity Code Description Project File Line Suppression State Warning Found conflicts between different versions of the same dependent assembly. Please set the "AutoGenerateBindingRedirects" property to true in the project file. For more information, see http://go.microsoft.com/fwlink/?LinkId=294190. LOS.iOS

    Monday, February 27, 2017 5:34 AM

Answers

  • User37696 posted

    @"JamesP.5698",

    For the iOS project, try changing the Linker settings to Don't Link in your project properties/options under the iOS Build menu. Let me know if that changes the behavior at all. Another quick thing to try is to remove (uninstall) the app from the device and then re-deploy.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, February 27, 2017 6:58 PM

All replies

  • User37696 posted

    @"JamesP.5698",

    For the iOS project, try changing the Linker settings to Don't Link in your project properties/options under the iOS Build menu. Let me know if that changes the behavior at all. Another quick thing to try is to remove (uninstall) the app from the device and then re-deploy.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Monday, February 27, 2017 6:58 PM
  • User138822 posted

    Thanks, I was able to finally figure it out last night. Just needed to delete the app and reinstall.

    Monday, February 27, 2017 7:03 PM
  • User268145 posted

    Dont work on my case, still can't built. Can i downgrade to previous cycle ???

    Friday, March 3, 2017 4:26 PM
  • User138822 posted

    There are options to download the previous version. You should try deleting your app on your phone first though. Then try reinstalling it after having upgraded to the new version. It also may help checking your linker options in Project Properties > Build

    Monday, March 6, 2017 9:53 PM
  • User270459 posted

    I tried the @JohnMiller advice but not worked. Them use this (image example) configuration in my VS2015 and it's work now.

    Tuesday, March 21, 2017 7:18 PM
  • User89714 posted

    I've just had to uninstall a previous version in order to overcome this issue. Makes me concerned about updates post-release.

    Sunday, September 10, 2017 12:38 PM