none
[RESOLVED] Cannot deploy WF "Could not etalish trust relationship for the SSL/TLS secure channel" RRS feed

  • Question

  • I get this error when deploying a Visual Studio 2013 Update 5 Workflow solution for SP2013 SP1 September 2015 CU & SQL Server 2014 & Windows Server 2012R2

    What tested :

    Not tried this MS article, I don't know the risk if something goes wrong on the SP server to rollback.. https://support.microsoft.com/en-us/kb/2545744

    Does anyone have tried this ?

    $rootCert = (Get-SPCertificateAuthority).RootCertificate
    New-SPTrustedRootAuthority -Name"localNew" -Certificate$rootCert

    After running the above commands, perform an IISReset on all servers in the farm.

    Any ideas of what could resolve this annoying error ?











    • Edited by SpawnBe Tuesday, January 19, 2016 1:32 PM
    Monday, January 18, 2016 9:35 AM

Answers

  • Solved :

    You need to register the workflow in order to deploy properly.

    When registering the WF, the domain was missing.

    It was only the server and port but not the domain between

    Register-SPWorkflowService –SPSite ‘http://yourserver’ –WorkflowHostUri ‘https://yourserver.yourdomain.xx:123456’.

    Then the deploy was successful in VS and goes correctly in SP 



    • Proposed as answer by Benny Botte Tuesday, January 19, 2016 2:57 PM
    • Marked as answer by SpawnBe Tuesday, January 19, 2016 2:58 PM
    • Edited by SpawnBe Wednesday, January 20, 2016 9:31 AM
    Tuesday, January 19, 2016 1:31 PM
  • If that not working properly, always delete the service in the Central Administration after each try in PowerShell:

    Remove the “Workflow Service Application Proxy”.

    Go to the Central Administration > Manage Service Application > Workflow Service Application Proxy > click on the Workflow Service… row and select Delete in the ribbon. Don’t check “Delete data..” just click OK .

    If you still get an error "Failed to query the OAuth S2S metadata endpoint at URI '...' /metadata/json/1"

    Then you can add the following parameter at the end of your commando :

    -Force –AllowOAuthHttp

    And if still doens't work (your a are lucky), check this out :

    Edit the host file C:\Windows\System32\Drivers\etc and add your server IP and the url of your site*

    For example : 10.10.1.1 yoursitename.com

    *Your site that you specified from here : Register-SPWorkflowService –SPSite ‘http://yourserver’

    Should register fine after the DNS changes (dont forget to undo the DNS changes after the WFM is registered)

    Last but not least, reinstall Workflow Manager 1.0

    1. Launch the Workflow Manager Configuration wizard and leave your Farm
    2. After the process done, open the control panel > Programs select “Uninstall a Program”.
    3. Find the following items in the programs list and, for each item, click Uninstall on the menu bar above the program list
    4. Workflow manager 1.0
    5. Workflow manager 1.0 client
    6. Service bus 1.0
    7. Windows Fabric
    8. On the SQL server delete the WFM related database (remember what you entered during the installation ?)
    9. Delete the following folder: C:\program files\WorkflowManager\1.0
    10. Reinstall the WFM



    • Marked as answer by SpawnBe Monday, January 25, 2016 2:46 PM
    • Edited by SpawnBe Tuesday, January 26, 2016 1:22 PM
    Monday, January 25, 2016 2:45 PM

All replies

  • Solved :

    You need to register the workflow in order to deploy properly.

    When registering the WF, the domain was missing.

    It was only the server and port but not the domain between

    Register-SPWorkflowService –SPSite ‘http://yourserver’ –WorkflowHostUri ‘https://yourserver.yourdomain.xx:123456’.

    Then the deploy was successful in VS and goes correctly in SP 



    • Proposed as answer by Benny Botte Tuesday, January 19, 2016 2:57 PM
    • Marked as answer by SpawnBe Tuesday, January 19, 2016 2:58 PM
    • Edited by SpawnBe Wednesday, January 20, 2016 9:31 AM
    Tuesday, January 19, 2016 1:31 PM
  • If that not working properly, always delete the service in the Central Administration after each try in PowerShell:

    Remove the “Workflow Service Application Proxy”.

    Go to the Central Administration > Manage Service Application > Workflow Service Application Proxy > click on the Workflow Service… row and select Delete in the ribbon. Don’t check “Delete data..” just click OK .

    If you still get an error "Failed to query the OAuth S2S metadata endpoint at URI '...' /metadata/json/1"

    Then you can add the following parameter at the end of your commando :

    -Force –AllowOAuthHttp

    And if still doens't work (your a are lucky), check this out :

    Edit the host file C:\Windows\System32\Drivers\etc and add your server IP and the url of your site*

    For example : 10.10.1.1 yoursitename.com

    *Your site that you specified from here : Register-SPWorkflowService –SPSite ‘http://yourserver’

    Should register fine after the DNS changes (dont forget to undo the DNS changes after the WFM is registered)

    Last but not least, reinstall Workflow Manager 1.0

    1. Launch the Workflow Manager Configuration wizard and leave your Farm
    2. After the process done, open the control panel > Programs select “Uninstall a Program”.
    3. Find the following items in the programs list and, for each item, click Uninstall on the menu bar above the program list
    4. Workflow manager 1.0
    5. Workflow manager 1.0 client
    6. Service bus 1.0
    7. Windows Fabric
    8. On the SQL server delete the WFM related database (remember what you entered during the installation ?)
    9. Delete the following folder: C:\program files\WorkflowManager\1.0
    10. Reinstall the WFM



    • Marked as answer by SpawnBe Monday, January 25, 2016 2:46 PM
    • Edited by SpawnBe Tuesday, January 26, 2016 1:22 PM
    Monday, January 25, 2016 2:45 PM