locked
DataFlow Can't Connect To SQL Source Dataset RRS feed

  • Question

  • I am working in Azure Data factory (v2) on moving data from CSV files to Azure SQL Database. The Copy data is working fine for moving data, but I need to do some modification on the data before importing it to Azure SQL Database. I am using the Data flow and I'm facing the issue that the pipeline is always failing because of the connection to the Sink dataset which is an Azure SQL Database.
    The error message is: DF-SRC-002 - 'tableName' (Table Name) is required - RunId: ****-***-***-***-****

    I would appreciate any help on this.
    Monday, December 2, 2019 8:51 AM

All replies

  • In the Source dataset for Azure SQL DB, have you selected the table that exists in the DB?


    If the response helped, do "Mark as answer" and upvote it
    - Vaibhav


    Monday, December 2, 2019 9:04 AM
  • Yes I did
    Monday, December 2, 2019 9:09 AM
  • Yes I did

    Sorry if I misunderstood. 

    You are getting data from CSV, processing it and loading to Azure SQL. The dataset should be sink dataset for Azure SQL. 

    But the Dataset name is - DF-SRC-002 and also error says - can't connect to source dataset. Shouldn't it be Sink dataset?


    If the response helped, do "Mark as answer" and upvote it
    - Vaibhav

    Monday, December 2, 2019 9:39 AM
  • It is a Sink dataset. And by the way I am getting the same error on Source dataset and Sink dataset when using Azure SQL Database:

    Operation on target dataflow1 failed: Job '****-***-***-***-**** failed due to reason: DF-SRC-002 'tableName' (Table Name) is required

    Monday, December 2, 2019 10:15 AM
  • This is weird , as it sounds like  connecting to SQL using DF is failing . 

    I did tried to use DF and was able to access Azure SQL . Can you please let me know as what is the activity you are trying to do in DF .?


    For a deeper investigation we need additional information . Please send an email to AzCommunity@microsoft.com with the below details. We will respond to the thread with our findings.

    Thread URL:https://social.msdn.microsoft.com/Forums/en-US/907245fb-5b2d-4d3e-aa24-bc13c62b283a/dataflow-cant-connect-to-sql-source-dataset?forum=AzureDataFactory
    Subscription ID:  
    RunID : ( of the failure ) 


    Thanks Himanshu



    Monday, December 2, 2019 11:43 PM
  • Hello Himanshu, thank you for your reply.

    I am using the DerivedColumn to do a simple modification on one of the columns like get month from a date. But the problem exists even if I choose the source as Azure SQL Database and try to preview data in the debug mode.

    Additional info are sent by mail.

    Tuesday, December 3, 2019 6:50 AM
  • Hey Joe , 

    I just wanted to check if  you are using the Azure SQL DB v2 or  v1 . DF will not work on V1 version . Can you please check and confirm ?


    Thanks Himanshu

    Wednesday, December 4, 2019 12:04 AM
  • How can I check the Azure SQL DB if v2 or v1?

    Wednesday, December 4, 2019 7:59 AM
  • Well I tried to repro the issue , but I was able to push data from a csv to azure sql . I am so sorry but i do not see any easy way to find the version on SQL DB . Can i suggest you please create a free version to Azure SQL and try to see if you can connect to that DB  from DF . Do you know as to when the current version of AZUre SQL DB was created ?  if its along time back , then it can be on V1 . Anyways creating a SQL DB and testing that will help us rule out few possibilities  . 

    Once we hear back from and you are still having the issue , we will arrange a support ticket so that someone can work with you . 


    Thanks Himanshu

    Wednesday, December 4, 2019 9:44 PM
  • How can I check the Azure SQL DB if v2 or v1?

    Please run below query in Azure SQL and share result.

    select @@version


    If the response helped, do "Mark as answer" and upvote it
    - Vaibhav

    Thursday, December 5, 2019 5:31 AM
  • I tried with a newly created database and the issue is still the same. This is a weird bug and it's blocking me from working on my project, someone from Azure support team should check it, otherwise I have to find an alternative.
    Thursday, December 5, 2019 8:05 AM
  • This does not mention if it's V1 or V2
    Thursday, December 5, 2019 8:06 AM
  • I sent an email with the details mentioned but didn't get a reply yet.
    Thursday, December 5, 2019 8:07 AM
  • Apology for the delay on my side  , we have replied back with the details . We have enabled free support ticket and now you can work with some one who has more access to you pipeline and possibly will be able to resolve the issue . 

    Thanks Himanshu

    Tuesday, December 10, 2019 7:59 PM
  • Thank you Himanshu, I have already opened a support ticket with Azure support, I had to upgrade my support plan. Once they they have an answer I will share here.

    Thanks, Joe.

    Thursday, December 12, 2019 1:05 PM