none
How to deploy BizTalk Orchestration exposed as WCF Service from local box to Test Server RRS feed

  • Question

  • Dear All,

    I Created a BizTalk application and exposed the Orchestration as wCF service on local box IIS 6.0.

    I need to deploy the same WCF Service on Test Server.

    What will be the easiest way to do that and how?

    Regards,

    vikingsss

    Thursday, October 4, 2012 10:56 AM

Answers

  • Look inti IIS and see if Virtual Directory was created or not by your MSI.

    "When you export an msi the Select Resources should list a System.Biztalk:WebDirectory for each WCF receive location. If you select this then the virtual directory is included in the msi file and this should be installed when you install the msi, not when you add the msi to Biztalk Admin Console."

    • Proposed as answer by Mohit Kumar Gupta Thursday, October 4, 2012 1:24 PM
    • Marked as answer by vikingss Tuesday, October 9, 2012 9:16 AM
    Thursday, October 4, 2012 12:22 PM
  • If you have a receive location defined for the WCF service, when you export the MSI it the MSI will contain the WCF service, so on the target machine, run the MSI and then import the MSI and it should work.

    If you have issues, check and make sure that the WCF services is using an application pool in IIS that is a member of the Isolated host group, make then check the receive location to make sure that is it pointing to the local IIS on the correct port.

    Are you getting an error? if so, please post.


    Bill Chesnut | BizTalk Server MVP | Mexia Consulting | Melbourne Australia
    http://www.biztalkbill.com
    Please indicate "Mark as Answer" if this post has answered the question.

    • Proposed as answer by Mohit Kumar Gupta Thursday, October 4, 2012 1:22 PM
    • Marked as answer by vikingss Tuesday, October 9, 2012 9:14 AM
    Thursday, October 4, 2012 1:12 PM

All replies

  • 1 : Export MSI from localBox.

    2 : Import MSI to Test Server

    3: Copy InetMgr Website Folder to TestServer .

    4 : Update Binding with New End Point

    Regards

    Mohit

    Thursday, October 4, 2012 10:59 AM
  • You can also use BizTalk Deployment Framework to automate the BizTalk deployments across different servers. It is always better to automate the deployment.

    HTH,
    Naushad Alam

    When you see answers and helpful posts, please click Vote As Helpful, Propose As Answer, and/or Mark As Answer
    alamnaushad.wordpress.com
    My TechNet Wiki "BizTalk Server: Performance Tuning & Optimization"

    Thursday, October 4, 2012 11:42 AM
    Moderator
  • Hi Mohit,

    I did the same but I am not able to browse my service. Getting The Page Cannot be Found. No errors in event viewer.

    I did not get what do you mean by updating with the EndPoint.

    My Web.config looks like as below:

     <service name="Microsoft.BizTalk.Adapter.Wcf.Runtime.BizTalkServiceInstance" behaviorConfiguration="ServiceBehaviorConfiguration">
            <endpoint name="HttpMexEndpoint" address="mex" binding="mexHttpBinding" bindingConfiguration="" contract="IMetadataExchange" />
            <!--<endpoint name="HttpsMexEndpoint" address="mex" binding="mexHttpsBinding" bindingConfiguration="" contract="IMetadataExchange" />-->

    Thursday, October 4, 2012 12:13 PM
  • Look inti IIS and see if Virtual Directory was created or not by your MSI.

    "When you export an msi the Select Resources should list a System.Biztalk:WebDirectory for each WCF receive location. If you select this then the virtual directory is included in the msi file and this should be installed when you install the msi, not when you add the msi to Biztalk Admin Console."

    • Proposed as answer by Mohit Kumar Gupta Thursday, October 4, 2012 1:24 PM
    • Marked as answer by vikingss Tuesday, October 9, 2012 9:16 AM
    Thursday, October 4, 2012 12:22 PM
  • check virtual directory was created or not ,

    browse svc file then copy the url to Address properties of Receive Location , check Application pool settings also .

    Thursday, October 4, 2012 12:40 PM
  • If you have a receive location defined for the WCF service, when you export the MSI it the MSI will contain the WCF service, so on the target machine, run the MSI and then import the MSI and it should work.

    If you have issues, check and make sure that the WCF services is using an application pool in IIS that is a member of the Isolated host group, make then check the receive location to make sure that is it pointing to the local IIS on the correct port.

    Are you getting an error? if so, please post.


    Bill Chesnut | BizTalk Server MVP | Mexia Consulting | Melbourne Australia
    http://www.biztalkbill.com
    Please indicate "Mark as Answer" if this post has answered the question.

    • Proposed as answer by Mohit Kumar Gupta Thursday, October 4, 2012 1:22 PM
    • Marked as answer by vikingss Tuesday, October 9, 2012 9:14 AM
    Thursday, October 4, 2012 1:12 PM
  • Hi All,

    How to check if my recieve location is pointing to the correct port?

    I have hosted it on port 83, may be recieve location pointing to default port 80..don't know where to specify.

    I am now getting Service Unavailable.

    Regards,

    vikingsss

    Monday, October 8, 2012 7:14 AM
  • Specify Address at Receive Location Properties

    URI Example : Localhost:83/DirectoryName/Service.svc

    Regards

    Mohit


    Monday, October 8, 2012 7:55 AM
  • nothing is working for me :(:(.

    I changed it to default app pool and Port 80.

    When trying to browse, I am getting HTTP Error 403 Forbidden

    "YOU ARE NOT AUTHORIZED TO VIEW THIS PAGE".

    Regards,

    vikingsss

    Monday, October 8, 2012 11:18 AM
  • Did you allow anonymous access on your Web Application?

    Morten la Cour

    Monday, October 8, 2012 11:39 AM
  • Hi All,

    I got it to work by installing the MSI on box and keeping everything default.

    But by default it is deploying in Default Website, how to get it hosted in some other WebSite through MSI installation.

    Regards,

    Vikash

    Tuesday, October 9, 2012 9:16 AM