none
Do I need net.frames earlier than 3.5 RRS feed

  • Question

  • I just diownloaded netframe 3.5 and see I still have the earlier versions. do I need them or can I delete them?
    Sunday, July 5, 2009 7:00 PM

Answers

  • Hi Jack Simpson,

    Referring to removal of any the earlier versions of the .NET Framework, it depends on the applications and OS that are ran on your PC.

    For OS, here is a useful blog that shows what version of .NET Framework is included in what version of OS. See: http://blogs.msdn.com/astebner/archive/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os.aspx
    .NET Framework is installed as the component of OS and cannot be removed.

    For applications, if you have some application based on .NET Framework 2.0 on your PC, you cannot remove .NET Framework 2.0.

    .NET Framework 3.5 includes .NET Framework 2.0 and .NET Framework 3.0 as the prerequisite. If .NET 2.0 and 3.0 are not installed on your machine, they will be automatically installed along with .NET Framework 3.5 installation. And these two .NET Frameworks cannot be removed if .NET Framework 3.5 has been installed.
    For more information of .NET Framework 3.5, see: http://msdn.microsoft.com/en-us/library/w0x726c2.aspx

    If you have any further concern, please feel free to let me know.

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Jack Simpson Tuesday, July 7, 2009 8:37 PM
    Tuesday, July 7, 2009 9:02 AM

All replies