locked
kb 2837628 removes search box RRS feed

  • Question

  • So after installing the most recent update to SharePoint 2013, search boxes have disappeared from all of my sites and when I create a basic search center I am met with an error page. does anyone have any advice on this? also, BE CAREFUL WITH THIS UPDATE

    Edit: I realized I include almost no specifics on this. There were 2 updates that hit today, kb 2837628 and kb 2837657, I'm testing to discover which one is the culprit that caused this.  kb 2837628 appears to be a fairly basic update according to Microsoft, appears to be mostly around excel pivot tables, and its fairly small. my gut tells me this is not the culprit. the other update was close to 300mb but includes no details at all about what it fixes. I'm thinking this is the culprit. It looks like the update was released just yesterday.


    • Edited by Theantioch Thursday, November 14, 2013 12:04 AM
    Wednesday, November 13, 2013 9:47 PM

Answers

All replies

  • Contrary to what I believed, kb 2837628 was a 500mb update, so much larger than I thought and kb 2837657 was about 100mb. I restored from a backup from the previous day, installed kb 2837657 first, and encountered no issues, I then installed kb 2837628 and immediately after install my search box was broken. my advice is don't install kb 2837628 until a fix is available


    • Edited by Theantioch Monday, December 2, 2013 8:35 PM
    Thursday, November 14, 2013 12:03 AM
  • I'm in the same case.

    No SearchBox anymore. 

    After windows updates, when i try to add a searchbox Webpart, i obtain the error message "Common language Runtime detected an invalid program".

    KB2837628 includes no details at all about what it fixes ...

    Very embarassing ...


    Monday, December 2, 2013 5:21 PM
  • Glad to see its not just me. I didn't try making a search box web part, but I did try a search center and got an error saying "unexpected error occurred" with a reference id. when I tried to hunt this down in the logs I found it, but none of the information presented helped with the problem. I hope you tried this in a test environment first? If not I did not see an easy way to roll back after applying the patch, as is the case with most SharePoint patches it doesn't appear uninstallable, out of curiosity did you run any database upgrades after applying the patch? I have tried it with and without and gotten the same results, but I wanted to see if it was different for you.
    Monday, December 2, 2013 8:34 PM
  • I'm in the same case.

    No SearchBox anymore. 

    After windows updates, when i try to add a searchbox Webpart, i obtain the error message "Common language Runtime detected an invalid program".

    KB2837628 includes no details at all about what it fixes ...

    Very embarassing ...



    I noticed Microsoft had updated the article on November 28th, but upon inspection the version numbers appear to be the same. As a test I installed this again into a backup copy of my farm; The error continues. I did however add a search box web part and I got the common language runtime error issue as well, so this is not an isolated issue.
    • Edited by Theantioch Monday, December 2, 2013 10:39 PM
    Monday, December 2, 2013 10:38 PM
  • Hopefully i did the migration of my sharepoint 2010 farm in a test environnement. ;)

    The ULS logs haven't tell me anythings to isolate the problem.

    I've banned the KB2837628 from our internal Windows Update Server.

    Now, I can migrate my farm without problem on the Search webpart.

    I hope Microsoft will patch the patch soon.

    I stay tuned. If i have more information, il will post on this topic.

    Regards,

    Friday, December 6, 2013 8:24 AM
  • I am in this situation, too.

    Search box disappeared from all my SharePoint pages.

    I hope Microsoft will issue a fix soon.

    Regards.

    Friday, December 6, 2013 1:11 PM
  • Just as an FYI a new update just hit today, KB2850058, This update appears to do the exact same thing as KB2837628. I have created a new topic on this here: http://social.technet.microsoft.com/Forums/sharepoint/en-US/4714d906-5bbe-4eca-b666-b0e65367a0a3/update-kb2850058-breaks-search?forum=sharepointsearch
    Wednesday, December 11, 2013 6:26 PM
  • I've opened a support case with Microsoft on this issue. I'll post updates to my post (http://www.sharepointblogs.be/blogs/vandest/archive/2013/12/10/sharepoint-foundation-2013-broken-search-experience.aspx) but also try to post them here.
    Thursday, December 12, 2013 3:08 PM
  • I managed to reproduce the issue and confirm it is caused by KB2850058. I hope Microsoft PSS can pick this up quickly. See here: http://www.sharepointblogs.be/blogs/vandest/archive/2013/12/10/sharepoint-foundation-2013-broken-search-experience.aspx

    Cheers

    Saturday, December 14, 2013 6:25 AM
  • A final word from the escalation engineer is that this will be fixed in the April 2014 Cumulative Update.

    http://www.sharepointblogs.be/blogs/vandest/archive/2013/12/10/sharepoint-foundation-2013-broken-search-experience.aspx

    If you can't live without Search until that time you'll have to set up a new environment and avoid said hotfixes.

    Wednesday, February 5, 2014 8:37 PM
  • 3 1/2 month update mark, Steven is still working with Microsoft towards a fix. Last we have heard from Microsoft is end of April, maybe, possibly. If your site is still broken DO NOT install SP1, this WILL NOT fix the issue and it will still break your search bar. 
    Wednesday, March 5, 2014 5:29 PM
  • This hotfix was just released and fixes the issue:

    http://support.microsoft.com/kb/2760625

    • Marked as answer by Theantioch Thursday, March 20, 2014 7:31 PM
    Thursday, March 20, 2014 6:59 PM