none
Installation of Microsoft BizTalk Server Adapter for Microsoft Dynamics CRM 4.0 RRS feed

  • Question

  • Dear all,

    I expanded our existing BizTalk Group by one server. After configuring the group feature I started to install all the needed adapters on the new machine. Theses adapters were already configured in the BizTalk group.

    This works fine for all adapters, except the CRM Adapter. The setup told me "Microsoft BizTalk Server Adapter for Microsoft Dynamics CRM 4.0 is already installed. Remove it and run Setuo again."

    But the adapter isn't installed on the machine. I use Windows 2008 Enterprise R1 64bit and BizTalk 2009.

    Thanks,
    Christopher

    Thursday, February 3, 2011 1:58 PM

Answers

  • You can copy all the microsoft.crm.biztalkadapter.*.dll from the GAC from the first server to the GAC on the other servers. Configure a host instance on the other servers and it will work using the dll's from it's own GAC.

    You can get the dll's from the GAC by clicking "Start" -> "Run" -> "C:\WINDOWS\assembly\gac_msil" and then browse through the folders.


    Avanade.com
    Tuesday, February 8, 2011 3:35 PM

All replies

  • Yeah the Dynamics CRM 4 adapter only works with one server in each group. This is unfortunately a known issue. I would switch to using the CRM web services rather than using the adapter.

    BTW, in Dynamics 2011 there is not a separate adapter and just a WCF service so the WCF adapters can be used.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Thursday, February 3, 2011 11:26 PM
    Moderator
  • Thanks for the information.

    I want to use the adapter only with one server, but I want to have it installed on every server. Is there any way to do this?

    Thanks.

    Monday, February 7, 2011 9:50 AM
  • I think the install fails the 2nd time you try to do it on any other server in the group. I see what you mean - it would be nice to have it work on any one server in the group if some other one server failed but unfortunately it only works on the first server you install it on. There is not really this level of granularity of the configuration of the adapter. Sorry.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Monday, February 7, 2011 5:15 PM
    Moderator
  • You can copy all the microsoft.crm.biztalkadapter.*.dll from the GAC from the first server to the GAC on the other servers. Configure a host instance on the other servers and it will work using the dll's from it's own GAC.

    You can get the dll's from the GAC by clicking "Start" -> "Run" -> "C:\WINDOWS\assembly\gac_msil" and then browse through the folders.


    Avanade.com
    Tuesday, February 8, 2011 3:35 PM