none
Your virtual machine may not have enough RAM? RRS feed

  • Question

  • Hello,

    While downloading WinCE image at emulator, I am getting error that "The specified CE boot image could not be loaded. Your virtual machine may not have enough RAM allocated. Try increasing the RAM allocation (if you are using Platform Builder open the Configure Remote Services dialog, choose the Emulator Download service, and click the configure button).".Please help me to resolve it.

    Thanks

    Anil

    Thursday, December 16, 2010 11:59 AM

All replies

  • It's telling you, if you are running the emulator from Platform Builder, to check/adjust the RAM size for the emulator.  Do this using the menu Target -> Connectivity Options...  Look for teh Target Device Connectivity Options dialog that appears (perhaps behind another window).  In that dialog, click on Kernel Service Map, and to the right of the Download: Device Emulator (DMA) drop down, click on the Settings button.  This will display the Emulator Properties dialog.  Check the Specify RAM size setting is checked and increase if your OS size exceeds the size specified.

    When running the emulator from the command line, you can specify the /memsize command line parameter to do the same thing.


    Tom Gensel PTG Systems, LLC
    http://www.ptgsystems.com
    Thursday, December 16, 2010 12:42 PM
  • Hi Tom,

    Thanks for reply. I tried that option with different RAM size from 32MB to 256MB but resulting the same error message.

    Anil

     

    Thursday, December 16, 2010 1:00 PM
  • Which version of CE are you using? Are you using the ARM Device Emulator, and does your OS project specify "Device Emulator: ARMV4I" as the BSP?


    Tom Gensel PTG Systems, LLC
    http://www.ptgsystems.com
    Thursday, December 16, 2010 1:08 PM
  • I am using WinCE 5.0 version and my OS project specify ARMV4I Device Emulator as the BSP.

    Anil

    Friday, December 17, 2010 5:25 AM