none
Start Debugging on on "Current Page"

    Question

  • Hi,

    I am using Visual Studio 2013 Professional (version 12.0 Update 5) for ASP.NET web applications. Previously, when I hit F5 to Start Debug on a project, the currently opened .aspx file would launch as a page on my browser (Chrome). But a few months ago, this stopped on all the projects that I was working on. The root (blank page) will always open. 

    I checked my project Properties > Web > Start Action, it is already set to Current Page. I have also checked that there is no Start Page set (Specific Page = blank).

    I've followed the advice on this link and ensured that .aspx and .aspx.cs files are opened by Visual Studio by default.

    What else should I do to change the setting back? 

    Thank you.

    Wednesday, June 29, 2016 2:22 AM

Answers

  • Hi Windhoek,

    >> but it still opens to the root folder instead of the "current" page.

    Could you share me a screen shot about this result? Not debug your app, just run your app using "start without debugging", how about the result?

    Do you set the IIS Express as the server in your VS IDE? Do you set the Specific page like the following screen shot?

    If all web apps have the same issue, if possible, run the command line:

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    After these, you can create a new web project in a new workspace to avoid if there’re any problems of the old workspace settings. If this issue is also exists, I think you need to reinstall/repair the VS.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, July 6, 2016 6:43 AM
    Moderator

All replies

  • Hi Windhoek,

    >>the currently opened .aspx file would launch as a page on my browser (Chrome). But a few months ago, this stopped on all the projects that I was working on. The root (blank page) will always open. 

    One suggestion is that you could install other browser like the IE 11, debug it again after you set it as the default browser, if it works well in IE 11 using the same VS IDE, I think it would be not the VS or project issue, we would think about the Chrome browser itself.

    If all browsers have the same issue for this web app, could you test a simple asp.net app or run the same app in other VS machine? I think we have to narrow down this issue firstly before we could find the real reason.

    Like the following screen shot, set the .aspx as the start page, and then run it using "view in Page Inspector", how about the result?

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, June 30, 2016 6:37 AM
    Moderator
  • Hi Jack,

    Thanks for your suggestions. I set IE as the browswer, but it still opens to the root folder instead of the "current" page.

    This issue happens on all my projects, even a simple web app.

    I set one of the .aspx as the start page and ran it using "view in Page Inspector". It launches that page, as expected. But that's not what I want. I want it to run the "current" page, meaning the page that is currently open and in focus in VS.

    Any other suggestions? Thank you.
    Wednesday, July 6, 2016 4:00 AM
  • Hi Windhoek,

    >> but it still opens to the root folder instead of the "current" page.

    Could you share me a screen shot about this result? Not debug your app, just run your app using "start without debugging", how about the result?

    Do you set the IIS Express as the server in your VS IDE? Do you set the Specific page like the following screen shot?

    If all web apps have the same issue, if possible, run the command line:

    Devenv.exe /ResetSettings: Restores the IDE's default settings, optionally resets to the specified VSSettings file.

    After these, you can create a new web project in a new workspace to avoid if there’re any problems of the old workspace settings. If this issue is also exists, I think you need to reinstall/repair the VS.

    Best Regards,

    Jack


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, July 6, 2016 6:43 AM
    Moderator