locked
VS keep showing Using Xamarin.Android with Visual Studio requires Business edition or higher. RRS feed

  • Question

  • User19386 posted

    I installed the latest version of Xamarin.Android and Xamarin.iOS for Visual Studio.

    Now when I try to load an Android project in Visual Studio, it keep showing that message :

    Using Xamarin.Android with Visual Studio requires Business edition or higher.

    Then, it ask me to connect to the internet to proceed which I am of course.

    Also, I have an Enterprise licence, so that step should not be a problem.

    Any else having the same issue?

    Wednesday, November 13, 2013 7:53 PM

All replies

  • User13708 posted

    If it makes you feel any better, the new release of Xamarin Studio is just as much of a trainwreck this morning. Someone must have pushed the release button before anything was tested.

    Wednesday, November 13, 2013 8:00 PM
  • User19386 posted

    Not really, but it's probably the last time we will update Xamarin the first following days of the Stable release. Not sure to understand why it went Stable though.

    Wednesday, November 13, 2013 8:04 PM
  • User400 posted

    I'm getting the please connect to the internet message too

    Wednesday, November 13, 2013 8:11 PM
  • User19386 posted

    From one of the support guy :

    Apparently it is just our activation server having issues. https://bugzilla.xamarin.com/showbug.cgi?id=16199 and https://bugzilla.xamarin.com/showbug.cgi?id=16193

    Wednesday, November 13, 2013 8:15 PM
  • User428 posted

    I am getting the same issue where I am told to "please connect to the internet to proceed". When I click on the little "?" button, it lauches a browser window which navigates to a Xamarin support page, on the internet, successfully. :)

    Wednesday, November 13, 2013 8:48 PM
  • User13121 posted

    Hi everyone,

    We're having some intermittent issues with the activation service, which is what you are seeing when you get the "Please connect to the internet to proceed" error.

    We're working hard to get it back up and running smoothly, thank you all for your patience.

    Tim

    Wednesday, November 13, 2013 8:51 PM
  • User19386 posted

    I passed the first step which was "not connected to the server"

    Now I get this issue:

    Xamarin.Components.Ide.ApiClients.ActivationException: Failed to look up user. at Xamarin.Components.Ide.Activation.ActivationService.GetErrorWorkflow(LicenseSyncResult[] results, Boolean ignoreSyncErrors) at Xamarin.Components.Ide.Activation.ActivationService.<GenerateFullWorkflowSequence>d__8a.MoveNext() at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step) at Xamarin.Components.Ide.Activation.ActivationDialog.<>c__DisplayClass13.<StartSpinnerTaskAndScheduleContinuation>b__12(Task t)

    I tried again and it is now :

    System.Net.WebException: The remote server returned an error: (500) Internal Server Error. at System.Net.HttpWebRequest.GetResponse() at Xamarin.Components.Ide.Web.RequestHelper.GetResponse(Func1 createRequest, Action1 prepareRequest, CancellationToken token) at Xamarin.Components.Ide.SSO.Client.DoRequest(String endpoint, String method, String body, CancellationToken cancellationToken) at Xamarin.Components.Ide.SSO.Client.CreateToken(String email, String password, CancellationToken cancellationToken) at Xamarin.Components.Ide.SSO.Client.<>c__DisplayClass5.<CreateTokenAsync>b__4() at System.Threading.Tasks.Task1.InnerInvoke() at System.Threading.Tasks.Task.Execute()

    Wednesday, November 13, 2013 8:54 PM
  • User19386 posted

    Working now.

    Wednesday, November 13, 2013 9:16 PM
  • User428 posted

    Working for me too, Thanks.

    Wednesday, November 13, 2013 10:05 PM
  • User1694 posted

    I'm having the same issue, but it's still not working for me.

    What did you do to make it work again?

    Thursday, November 14, 2013 8:56 AM