locked
Problem updating library content type associate with workflow RRS feed

  • Question

  • I have a content type in Excel format in a document library. Users upload a PDF to this libray and run a workflow on PDF to generate an Excel file with customized columns. It's working fine, however now I need to but have problem updating that content type in Excel format.

    I have edited the Excel template by clicking on 'edit' in Library settings\content type\Advanced settings. Somehow the WF still pulled the old template. I tried to upload a new template but not working either. I thought the content type may have been hardcoded in WF so I checked the WF in SPD 2007 and could not see any template is associated with it.

    I then created a new WF by modeling the exsiting one. However, when I ran the WF on a PDF file, it generated a PDF instead, and failed to open anyway.

    Please advise how should I update this template.

    Thanks
    CC

    Saturday, June 16, 2012 4:31 PM

All replies

  • Ok updating content type template is actually straight forward.

    Now the problem I still have not solved is once I uploaded a PDF file to the library and ran the WF to create a new Excel file which is my default and only template, a ghosted PDF file was generated instead of an Excel file.

    Any suggestion?

    Thanks
    CC

    Monday, June 18, 2012 1:34 PM