none
Error: Unable to find fileDFUI.exe please verify your install is correct.

    Question

  • I am getting the following error, whenever I add an existing Asp.Net web application as existing web role project.

    --------------------------------------------------------------------------------------------------------

    Microsoft Visual Studio

    Unable to find fileDFUI.exe please verify your install is correct.

    OK

    --------------------------------------------------------------------------------------------------------

    I am using Nov 2011 SDK via WPI.

    Steps to recreate:

    1. Create an empty Azure project (without any role).

    2. Add an existing  Asp.Net MVC3 project to the solution.

    3. Right click on role to "Add an existing web role project in solution" to point to just added project.

    4. Rebuild and run to see the error.

     

    Please help.

     

     

     

     

    Thursday, November 24, 2011 9:31 AM

Answers

  • The cause of the issue is that visual studio tries to load DFUI.exe from AppData temp directory, i.e. C:\Users\<username>\AppData\Local\assembly\dl3\GPO8L9XL.JW4\X9X8K6MA.13N\139aad8f\00a876bf_fa99cc01\DFUI.exe


    DFUI.exe doesn't exist in AppData directory so visual studio reports the error. In SDK 1.5, visual studio reads a registry key to find the correct location. However it looks like that the registry lookup is removed in SDK 1.6.

    Currently one of the workarounds is to copy ALL the files under C:\Program Files\Windows Azure Emulator\emulator to the AppData temp directory. Note the temp directory path may be different on your machine. You can find the path by using Process Monitor.
    http://technet.microsoft.com/en-us/sysinternals/bb896645
    Please run process monitor and reproduce the issue in visual studio. Search DFUI.exe in the log and you will find the path.


    Thanks,
    Carson


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by eprafulla Wednesday, November 30, 2011 10:07 AM
    Wednesday, November 30, 2011 9:59 AM

All replies

  • Hi,

    Can you try to reinstall Windows Azure SDK? Also check your installation directory to make sure fileDFUI.exe exists. If it still doesn’t work, I would like to suggest you to check your installation logs.

     

    Best Regards,

    Ming Xu.


    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Friday, November 25, 2011 3:11 AM
    Moderator
  • Thanks for the suggestion. I tried following without success:

    1. Reinstalled Windows Azure Nov 2011 SDK.

    2. DFUI.exe does exists in C:\Program Files\Windows Azure Emulator\emulator\devfabric

    I am using Visual Studio 2010 with Windows7 x64 Ultimate and SQL Server 2008 R2 Express (v10.50.1617.0). SQL Server instance do not use default name "SQLExpress".

    I could recreate the issue with another machine with similar configuration.

    Storage emulator was not starting due to SQL Server instance name not being "SQLExpress". I configured the storage emulator using DSInit /sqlInstance:<SQLServerInstance>. It fixed the storage emulator. On manually started both storage and compute emulators and Visual Studio 2010, I can no longer see this error.

    Edit: The error is back. Not sure what is the cause now. Unmarked as answer.

    • Proposed as answer by Mahesh J Friday, November 25, 2011 8:21 AM
    • Marked as answer by eprafulla Sunday, November 27, 2011 2:09 PM
    • Unmarked as answer by eprafulla Monday, November 28, 2011 11:57 AM
    • Edited by eprafulla Monday, November 28, 2011 11:58 AM
    Friday, November 25, 2011 4:34 AM
  • Eprafulla,

    i experienced the same issues and at my site it seemed pretty random when that message occured. I found out that (at least at my configuration) starting a second instance of VS2010 actually did work. Pretty weird but a workaround for me.

    regards

    Monday, November 28, 2011 12:14 PM
  • Yes, it worked for me as well, for some time. But the error is back and this time it is persistent. Rolling back to Sept 2011 SDK.
    Tuesday, November 29, 2011 1:14 AM
  • The cause of the issue is that visual studio tries to load DFUI.exe from AppData temp directory, i.e. C:\Users\<username>\AppData\Local\assembly\dl3\GPO8L9XL.JW4\X9X8K6MA.13N\139aad8f\00a876bf_fa99cc01\DFUI.exe


    DFUI.exe doesn't exist in AppData directory so visual studio reports the error. In SDK 1.5, visual studio reads a registry key to find the correct location. However it looks like that the registry lookup is removed in SDK 1.6.

    Currently one of the workarounds is to copy ALL the files under C:\Program Files\Windows Azure Emulator\emulator to the AppData temp directory. Note the temp directory path may be different on your machine. You can find the path by using Process Monitor.
    http://technet.microsoft.com/en-us/sysinternals/bb896645
    Please run process monitor and reproduce the issue in visual studio. Search DFUI.exe in the log and you will find the path.


    Thanks,
    Carson


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by eprafulla Wednesday, November 30, 2011 10:07 AM
    Wednesday, November 30, 2011 9:59 AM
  • Thanks Carson for the cause and workaround. 
    Wednesday, November 30, 2011 10:08 AM
  • This is a mayor bug, this happened to me in 2 dev machines all of a sudden, Microsoft should make an update immediatly I don't know why the delay this is urgent, the workaround is not acceptable
    Thursday, December 22, 2011 7:33 PM
  • The cause of the issue is that visual studio tries to load DFUI.exe from AppData temp directory, i.e. C:\Users\<username>\AppData\Local\assembly\dl3\GPO8L9XL.JW4\X9X8K6MA.13N\139aad8f\00a876bf_fa99cc01\DFUI.exe


    DFUI.exe doesn't exist in AppData directory so visual studio reports the error. In SDK 1.5, visual studio reads a registry key to find the correct location. However it looks like that the registry lookup is removed in SDK 1.6.

    Currently one of the workarounds is to copy ALL the files under C:\Program Files\Windows Azure Emulator\emulator to the AppData temp directory. Note the temp directory path may be different on your machine. You can find the path by using Process Monitor.
    http://technet.microsoft.com/en-us/sysinternals/bb896645
    Please run process monitor and reproduce the issue in visual studio. Search DFUI.exe in the log and you will find the path.


    Thanks,
    Carson


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Sorry, but is not a solution to the problem.  Is Microsoft going actully give a solution to this problem?
    Wednesday, January 4, 2012 6:32 PM
  • Exactly. This is a bug that needs to be fixed, this product is out of Beta guys... My clients wouldn't accept this from me
    Wednesday, February 8, 2012 4:39 PM
  • +1 from us here... this is so annoying... please fix


    /Johan

    Monday, March 12, 2012 2:26 PM