locked
Move sitecollection from on Webapp to another webapp RRS feed

  • Question

  • Hi Team,

    We have a web application Webapp1 and it contains multiple sitecollections Sitecolection1,Site collection2 etc

    Webapp1

    Sitecollection1

    Sitecollection2

    Sitecollection3

    ....

    We have one more webapplocation WebApp2 and multiple site collections.

    Sitecollection21

    Sitecollection22

    Sitecollection23

    is there a way where in I can move all the site collections from Webapp1 to Webapp2.

    So that Sitecolection2 has

    Sitecollection1

    Sitecollection2

    Sitecollection3

    Sitecollection21

    Sitecollection22

    Sitecollection23

    Thank you,

    Vinay

    Wednesday, March 26, 2014 3:55 PM

Answers

All replies

  • You can do this one of two ways:

    1) Detach the content database(s) from WebApp1 containing SiteCollection1, 2, 3 and attach it to WebApp2.

    2) Use Backup-SPSite for SiteCollection1, 2, 3 on WebApp1, delete the Site Collections, and then use Restore-SPSite to WebApp2.


    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, March 26, 2014 4:08 PM
  • We want to go through Content db route.

    When you say detach ,what Command do we need to you.

    Can you give an example please.

    Wednesday, March 26, 2014 4:46 PM
  • Use Dismount-SPContentDatabase on WebApp1 and Mount-SPContentDatabase on WebApp2.

    Trevor Seward

    Follow or contact me at...
      

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Wednesday, March 26, 2014 4:48 PM
  • One more Question - Currently we have these two web apps in staging and we are trying to take it to production for the first time as ewe dont have prod yet.

    so as I see it we need to first have both these webapps in staging then detach and attach and then delete the webapp1 after all of sitecollections are copied to Webapps.

    is that correct?

    Wednesday, March 26, 2014 5:09 PM