locked
BizTalk WCF service over SSL -WSDL is not working RRS feed

  • Question

  • we are exposed BizTalk Schema as Service and deployed in both IIS servers.BTW IIS cluster working as a loadbalancer.

    First Question:

    The service is exposed over SSL and shared URL like https://DNSName/abc.svc.When they browse the URL with WSDL nothing is getting (i.e.https://DNSName/abc.svc?wsdl).

    Please help me why WSDL is not generating

    Second Question:

    Exposing service over SSL and in web.config making httpgetenabled=true and endpoint name="HttpMexEndpoint enabled.

    Then when we browse URL(i.e.https://DNSName/abc.svc) it displaying like http://ipadress/abc.service?wsdl.

    So when we click on http://ipadress/abc.service?wsdl ,the wsdl is generated.

    Why when we try http://DNSName/abc.service?wsdl ,wsdl not generated.

    Instead of  displaying IPAddress to end user, we want to display DNSName.how to do it?


    Regards BizTalkWorship

    Monday, February 23, 2015 11:17 AM

Answers

  • Hi,

    For the problem of SVC file changing to WSDL when you bowse, this normally happens when "httpsHelpPageEnabled" property (in case of HTTPS as your case otherwise httpHelpPageEnabled) of you service is set to "false" in service's web.config file. When the help page option is set to "false" in the service's web.config file, this happens. Change it to  "true"

    <serviceDebug httpHelpPageEnabled="true"

    Regards,

    M.R.Ashwin Prabhu


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    • Marked as answer by Angie Xu Tuesday, March 3, 2015 11:04 AM
    Monday, February 23, 2015 2:56 PM

All replies

  • If you're getting it from IP and not from the hostname (DNS name entry) then it is a DNS related issue which you can check through NSLOOKUP. When you execute NSLOOKUP <DNSName> you should get the IP address for which you're getting the WSDL. If not then get this fixed first.

    Secondly, have you verified that the NLB is working before having published your service?

    Have you ensured that the Host Instance associated with the WCF-Custom receive location is running on BOTH the nodes of the NLB Cluster?

    Regards.

    Monday, February 23, 2015 12:35 PM
  • Hi,

    For the problem of SVC file changing to WSDL when you bowse, this normally happens when "httpsHelpPageEnabled" property (in case of HTTPS as your case otherwise httpHelpPageEnabled) of you service is set to "false" in service's web.config file. When the help page option is set to "false" in the service's web.config file, this happens. Change it to  "true"

    <serviceDebug httpHelpPageEnabled="true"

    Regards,

    M.R.Ashwin Prabhu


    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful by clicking the upward arrow mark next to my reply.

    • Marked as answer by Angie Xu Tuesday, March 3, 2015 11:04 AM
    Monday, February 23, 2015 2:56 PM