locked
Roll back WCF 5.6.0? Uninstall it? Help! RRS feed

  • Question

  • Ok, we just take on an offshore company to help with some of the work. And although they have no idea how, OData, Edm and Dataservices where upgraded to 5.6. That is a problem for our application which is going out on the 26 and we require at least a month's worth of testing.

    I tried to roll back the install, upgraded the service references etc. I searched ever file of any extension in the project that I could find and made sure that 5.6 was gone. The application refuses to compile, it cannot find a 'Parse' method or a 'Format' method only available in 5.6. I deleted the service references, rebuilt the services project, and added them back, it referenced them as 5.6.

    I admit I'm new to NuGet, and I need to know how to roll this back. The application is dead in the water.

    Thursday, December 12, 2013 4:50 AM

Answers

  • I tried that but it would not allow it with an error of a newer version is already installed. Then I used Uninstall-Package and that seemed to work but the next time I ran the project it reinstalled 5.6! I finally got it to stop but the Silverlight side of the project keep complaining that it wanted Dataservices 5.6 so I went out to the location it expected 5.6 to be located at (under program files (x86) and I made a copy of the 5.0 that was located there and I changed the name of the copy to 5.6. Now it works, although it's a hack.

    Thanks,

    Freddie Richard

    Friday, December 13, 2013 1:23 PM

All replies

  • Hello,

    >>I need to know how to roll this back

    Have a try to use the Package Manager Console to install the version that you want like below:

    Install-Package Microsoft.Data.Services -Version 5.5.0

    It will uninstall the current version of the project and install the specified version.

    For opening Package Manager Console, select the Tools -> Library Manage Package -> Package Manager Console.

    If I have misunderstood, please let me know.

    For details, please refer to link below:

    http://www.nuget.org/packages/Microsoft.Data.Services/5.5.0

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Friday, December 13, 2013 9:01 AM
    Moderator
  • I tried that but it would not allow it with an error of a newer version is already installed. Then I used Uninstall-Package and that seemed to work but the next time I ran the project it reinstalled 5.6! I finally got it to stop but the Silverlight side of the project keep complaining that it wanted Dataservices 5.6 so I went out to the location it expected 5.6 to be located at (under program files (x86) and I made a copy of the 5.0 that was located there and I changed the name of the copy to 5.6. Now it works, although it's a hack.

    Thanks,

    Freddie Richard

    Friday, December 13, 2013 1:23 PM