Windows 10 - Database exception error RRS feed

  • Question

  • Using Windows 10

    I wrote a small database program a long while back and compiled it on Windows XP. I have been using it on Windows 7 after I installed the runtime.

    So, I installed the runtime on Windows 10.

    Still, I am getting this exception:

    ************** Exception Text **************
     System.IO.FileNotFoundException: Could not load file or assembly 'System.Data.SqlServerCe, Version=, Culture=neutral, PublicKeyToken=89845dcd8080cc91' or one of its dependencies. The system cannot find the file specified.

    I tried installing the Version 4 runtime but that did not work either.

    Is there a solution?

    Saturday, December 21, 2019 6:12 PM


  • Found the problem.

    About two years ago, I tried my program on a windows 10 computer using the runtime SP2 version I had at the time, did not do any compatibility changes, and it seemed to run fine.

    I was trying to use the SP1 version. It did not work even in compatibility mode.

    I had to find my SP2 version.

    I now have the program working with SP2 Runtime version without compatibility enabled.

    • Marked as answer by ErikEJMVP Sunday, December 22, 2019 8:47 AM
    Saturday, December 21, 2019 9:17 PM