none
Text is not hiding in OOXml RRS feed

  • Question

  • With vsto I am trying to hide/unhide a particular paragraph in the document this works fine for word 2007, but it is not hiding for word 2013

    Please find OOXML part of word

    -<w:p w:rsidRDefault="007D06C4" w:rsidR="007D06C4">

    -<w:pPr>

    <w:pStyle w:val="APPracticalBulleted"/>

    -<w:numPr>

    <w:ilvl w:val="1"/>

    <w:numId w:val="8"/>

    </w:numPr>

    <w:ind w:left="1080"/>

    <w:divId w:val="1731733867"/>

    </w:pPr>

    -<w:r>

    -<w:rPr>

    <w:vanish w:val="0"/>

    </w:rPr>

    <w:t>Sample text;</w:t>

    </w:r>

    </w:p>


    • Edited by bevara Tuesday, September 1, 2015 9:49 AM
    • Moved by Fred Bao Wednesday, September 2, 2015 1:23 AM Office Related
    Tuesday, September 1, 2015 9:37 AM

Answers

  • Hi bevara,

    Upon further investigation, it turns out that if you change the view mode to Reading, you will see that Word 2013 respects the hidden text font attribute (i.e. <vanish>). Therefore, it is implemented but not for edit mode in 2013. You might see the same behavior in the web app version of Word.

    17.3.2.41 vanish (Hidden Text) does not specify or prescribe where/when the feature of hidden text is to be observed/respected in an application and for that reason, Word is conforming to the standard.

    Let me know if this is not clear.

    Thanks,

    Tom

    Tuesday, January 5, 2016 9:37 PM
    Moderator

All replies

  • Hello bevara,

    Since this issue is related with office, I move it to the office forum.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, September 2, 2015 1:22 AM
  • Hi bevara,

    First I apologize for the delayed response on this thread.

    I've verified that in Word 2013, toggling the hidden property on a run doesn't seem to hide the text for that run even though the <vanish> element is present in the <rPr> section.

    Word 2016 seems to respect <vanish> however.

    I will report this to the Word product support team and update if there is more information or a workaround.

    Thank you for bringing this to our attention.

    Best regards,
    Tom Jebo
    Microsoft Open Specifications 

    Wednesday, December 30, 2015 2:55 AM
    Moderator
  • Hi bevara,

    Upon further investigation, it turns out that if you change the view mode to Reading, you will see that Word 2013 respects the hidden text font attribute (i.e. <vanish>). Therefore, it is implemented but not for edit mode in 2013. You might see the same behavior in the web app version of Word.

    17.3.2.41 vanish (Hidden Text) does not specify or prescribe where/when the feature of hidden text is to be observed/respected in an application and for that reason, Word is conforming to the standard.

    Let me know if this is not clear.

    Thanks,

    Tom

    Tuesday, January 5, 2016 9:37 PM
    Moderator