none
document.getelementbyid(' ... ').Controller is null or not an object RRS feed

  • Question

  • Hi,
    I creat my report and view it by microsoft reportviewer in development machine.
    when I publish it on Host Server , I get some java script errors.
    ( I Instaled reportviewer.exe alreadey.)
    when iI click on Next or Previuse button on reportviewer toolbar get this error:
    document.getelementbyid(' ... ').Controller is null or not an object.
    OS os server is win2003 server
    IIS ver. : 6
    plz. help me.
    tnx
    Saturday, August 16, 2008 10:00 AM

Answers

  • Hi, I'm so happy because of underestanding the soloution.
    Just Do This Steps:
    1. Open IIS MMC
    2. Select Your Website
    3.Right Click on it and get properties
    4. On Properties Page>>Home Directory Tabpage Click On Configuratios button
    5. On Mapping Tabpage select row with contains .xsd
    6.click on Edit button
    7. remove check mark of verify that file exists
    8. Ok


    Refresh You Page and enjoy!

    tnkx for helpful note :

    http://www.themssforum.com/SVCS/RSClientController-undefined /

    Monday, August 18, 2008 9:08 AM

All replies

  • check to see if Java is disabled. 


    Living my life at 123mph in 11.15 seconds
    Saturday, August 16, 2008 11:58 AM
  • Do you have inside the report viewer into update panel?
    If yes you will get this problem because report viewer 9.0 does not support update panel.
    Eagle
    Sunday, August 17, 2008 4:23 PM
  • Hi, I'm so happy because of underestanding the soloution.
    Just Do This Steps:
    1. Open IIS MMC
    2. Select Your Website
    3.Right Click on it and get properties
    4. On Properties Page>>Home Directory Tabpage Click On Configuratios button
    5. On Mapping Tabpage select row with contains .xsd
    6.click on Edit button
    7. remove check mark of verify that file exists
    8. Ok


    Refresh You Page and enjoy!

    tnkx for helpful note :

    http://www.themssforum.com/SVCS/RSClientController-undefined /

    Monday, August 18, 2008 9:08 AM