locked
Login failed for user 'sa' RRS feed

  • Question

  • I get this error:

    sqlcmd -U sa@i6xc5ilom2 -P mypassword -S tcp:i6xc5ilom2.ctp.database.windows.net -d master
    Messaggio 18456, livello 14, stato 1, server i6xc5ilom2, riga 1
    Login failed for user 'sa'.

    Could it be because I'm using italian language settings?

    Thank you.

    Saturday, September 26, 2009 5:15 PM

Answers

  • Hi Carlo,

    If you would like to send me your Live Id and Server, I would be happy to take a look.

    Thanks for using the bits,
    Dave
    Thursday, October 8, 2009 3:57 AM

All replies

  • Double check that you have master database in your SQL Azure account. Also, instead of sa try connecting using  SQL Azure username and password. You can easily test your connection using

    https://onlinedemo.cerebrata.com/SQLAzureClient/default.aspx

    abhi
    http://www.zimbatech.com


    Enterprise Architect
    Sunday, September 27, 2009 1:20 AM
  • I have master and my custom db.
    Using sa user with cerebrata web tool I get "unable to retrieve database list" error.
    What is SQL Azure username and password? O have just sa. How can I create new user if I cannot connect to master db? Is it possible to create new user from SQL Azure web site?

    Thank you.
    Sunday, September 27, 2009 6:28 AM
  • Use the user name that you created your SQL Azure account as (caall?), it is the user name that lets you logon to https://sql.azure.com to access your Server Information page.  When you were setting up your account, you had to create this user name and a password, so you would use this name in the -U argument, such as -U caall@i6xc5ilom2

    See also this help topic, http://msdn.microsoft.com/en-us/library/ee336280.aspx.

    - Derek Harmon
    • Proposed as answer by DerekH Sunday, September 27, 2009 7:00 AM
    Sunday, September 27, 2009 7:00 AM
  • no it doesn't work.

    Anyway I solve creating a new profile with a new promo code received by Microsoft and the new one works.
    I think my first activation with a different promo code from Microsoft failed. I wonder how can I ask support to check the first profile.

    Thank you.
    Sunday, September 27, 2009 2:31 PM
  • if the password include some special characters(for example %^&), you need use "" to enclose it.
    try this:

    sqlcmd -U sa@i6xc5ilom2 -P "mypassword" -S tcp:i6xc5ilom2.ctp.database.windows.net -d master
    Friday, October 2, 2009 6:10 AM
  • Hi Carlo,

    If you would like to send me your Live Id and Server, I would be happy to take a look.

    Thanks for using the bits,
    Dave
    Thursday, October 8, 2009 3:57 AM
  • Hi Dave and thank you for reply.
    My Live ID is c.allegretti (at) multimodo.it
    My server is tcp:i6xc5ilom2.ctp.database.windows.net

    Bye
    Carlo

    Thank you Carlo
    Friday, October 9, 2009 11:45 AM