locked
ASMX web-service over HTTP and HTTPS RRS feed

  • Question

  • User1966648016 posted

    I have a web-service I'm trying to call from within a Silverlight app. Running unencrypted (http) it works just fine. Over HTTPS, I simply don't get a response. The service is simple data retrieval, nothing more. Am I missing something here? I've never really worked with HTTPS before.

    Tuesday, May 10, 2011 10:11 AM

All replies

  • User-1659704165 posted

    Hi,

    http://www.silverlightshow.net/items/Consuming-ASMX-Web-Services-with-Silverlight-2.aspx

    have Seen the above link?

    Tuesday, May 10, 2011 12:05 PM
  • User1966648016 posted

    As much as I'm grateful for your answer, it appears you did not read my initial post. My web-service works already, so that article is of no use to me.

    My problem is that it's not responding over HTTPS, it works just as intended otherwise. Also, that article shows the most basic way of connecting to a webservice, while I used that as a start, my code for calling the webservice automatically calls back to the issueing server as opposed to a hard coded one.

    Tuesday, May 10, 2011 6:24 PM
  • User967319531 posted

    Can you open the link to the webservice in a browser? Do you get a response then? Might be that there is simply no binding for https on your webservice. Also a pretty good tool for testing your webservice: http://www.eviware.com/soapUI/soapui-products-overview.html

    Tuesday, May 10, 2011 6:29 PM
  • User-1659704165 posted

    Have You seen the Cross-Domain xml or tried?

    <allow-from http-request-headers="SOAPAction">

              <domain uri="http://*"/>

               <domain uri="https://*" />

    http://timheuer.com/blog/archive/2008/10/14/calling-secure-services-with-silverlight-2-ssl-https.aspx

    http://channel9.msdn.com/Blogs/mtaulty/Silverlight-Calling-HTTPS-Web-Services

    Wednesday, May 11, 2011 11:49 AM
  • User1966648016 posted

    I can call the service directly in my browser, but it won't give me any results, just placeholders, saying it has to be run locally. Which is the same thing I get when running it in browser over HTTP. I do have in my client access file the rules for allowing https and http, but still nothing.

     

    <?xml version="1.0" encoding="utf-8"?>
    <access-policy>
      <cross-domain-access>
        <policy>
          <allow-from http-request-headers="SOAPAction">
    	<domain uri="http://*"/>
    	<domain uri="https://*"/>
          </allow-from>
          <grant-to>
            <resource path="/" include-subpaths="true"/>
          </grant-to>
        </policy>
      </cross-domain-access>
    </access-policy>

    Wednesday, May 11, 2011 5:44 PM
  • User-1269009881 posted

    Hi,

    You can try calling your ASMX web-service through console application. See whether it wokrs?


    Best regards,
    Peter

     

    Sunday, May 15, 2011 10:45 PM
  • User751929206 posted

    Same problem.... Please give solution if you found already.

    Tuesday, May 19, 2020 12:25 PM