none
Deploy First Basic Project Solution RRS feed

  • Question

  • Hi,

    My name is Greg Maxey.  While I posted quite a bit over the years in other Microsoft Support forums, this is (I think) my first post here.  I've done a fair amount of tinkering with Word and VBA, and recently decided that I want to test the water and try VSTO.  I have Visual Studio 2010 Professional installed on my home PC.

    I'm taking baby steps here and if I don't fall down too hard in the beginning and give up, I expect that I may be back many, many times for additional assistance in the future.  If my experience with VSTO is anything like my experiences with VBA, then if you all are patient with me, then one day I may understand enough to start answers a few questions post here ;-).  Enough introduction.

    After some personal coaching on basics yesterday, today I created my first simple add-in for Word.  It simply adds a new custom tab to the ribbon with a single group and single button. When the button is clicked, a simple msgbox appears.  After building the solution, I can start Word and my tab is there with its group and functioning button.

    Now I am trying to "package" this solution into something I can send to a friend where all they have to do is run a "Setup.exe" file and the add-in will be installed on their PC.  Here I have hit the wall.

    I downloaded and installed a program called "InstallShield LE" and while it was no walk in the sun, after viewing the video tutorial on the company website, I managed to create an installer project (which is embedded in my basic project solution). 

    I do not have a VeriSign or other paid for certificate, but I signed this new project using the testing certificate I created for my main project.  When I build this solution it reports "Build Succeeded." 

    When I execute the setup.exe file everything runs normally and it looks like it will be successful.  I even get a report that my project is installed and it appears in Control Panel "Programs and Features."  However, when I open Word, my tab does not appear and when open Developer>COM Add-Ins I don't see it there either.

    I am obviously doing something wrong.  Any ideas?  Thanks.

     


    Greg Maxey Please visit my website at: http://gregmaxey.mvps.org/word_tips.htm

    Friday, November 21, 2014 6:11 PM

Answers

All replies

  • Hello Greg,

    What Office version do you have installed on the problematic PC?

    Did you check out the required windows registry keys for the add-in?

    See Registry Entries for Application-Level Add-Ins for more information.

    Friday, November 21, 2014 6:37 PM
  • Eugene,

    Thanks for the reply.  I wish I could say it has solved my problem. However, it only confirms that I've not done things correctly and leaves me spinning my wheels on "how" to fix it.

    I have Office 2013, 2010, 2007 and 2003 installed. However, I typically work with Word 2010.

    Until looking at link, I didn't know that I had to create registry keys. I just assumed that since whatever was required was created when I did the build then it would be created when the setup.exe ran.

    It seems that I need to define a registry key:

    HKY_Local_Machine\Software\Microsoft\Office\Word\Addins\add-in ID

    where add-in ID is the name of my add-in.  While perhaps not ideal, my solution name is "Beginner Word Add-In."  It has two projects "Beginner Word Add-In" and "Basic Installer."  So which do I use as the add-in ID?

    Where do define these registry entries?  I went to the "Basic Installer" Project Assistant and see a icon for "Application Registry",  I can expand a tree "HKey_Local_Machine>Software (32 byte), but that is as far as it goes.  It won't drill down to \Microsoft\Word\Addins.  I did confirm that key does exist in the registry as I have other COM AddIns installed.  Do I have to recreate these keys in InstallSheild LE even though they are already present in the registry?

    When I get the registry keys and keywords defined, how do I determine things like "Manifest" Required. The full path of the deployment manifest for the add-in. The path can be a location on the local computer, a network share (UNC), or a Web server (HTTP)?

    As I said, all this is completely new to me.  Sorry and thanks again.

     


    Greg Maxey Please visit my website at: http://gregmaxey.mvps.org/word_tips.htm

    Friday, November 21, 2014 7:22 PM
  • Well I'm going to have to admit defeat unless more assistance is forth coming ;-).  I've been trying all day with no luck to install the solution via the setup.exe file.

    I've added (as best I can tell) the required registry keys in the setup project.  When I build the setup project I get notification of "Build Succeed."  When I open Word, I see my addin is loaded and my tab appears.

    When I look in the registry there is a new key in the HKey_Current_User\Software\Microsoft\Office\Word\Addins\The Anchorage.Beginner Word Add-in.  The "Manifest" key reads:

    file:///d:/My Documents/Visual Studio 2010/Projects/Beginner Word Addin/Beginner Word Addin/bin/Release/Beginner Word Addin.vsto|vstolocal 

    There are no new keys in HKey_Local_Machine.

    I then delete the new key, and delete the add-in from Word.

    Next I run the setup file.  It appears to run successfully, but when it is done and I start Word there is still no add-in loaded or new tab.

    When I look at the registry there are new keys in both HKey_Current_User and HKey_Local_Machine:

    HKey_Current_User\Software\Microsoft\Office\Word\Addins\The Anchorage.Beginner Word Add-in

    HKey_Local_Machine\Software\Microsoft\Office\Word\Addins\The Anchorage.Beginner Word Add-in

    The "Manifest" key in both reads:

    file:///C:\Program Files (x86)\The Anchorage\Beginner Word Addin\Beginner Word Addin.vsto|vstolocal

    The only difference I see is the slashes after the first three are reversed.

    I thought perhaps that since there were two keys with the same manifest sting that perhaps Word was confused and just ignored both, but after deleting the one in the Local_Machine key the result was the same.  No add-in, no tab.

    I then changed the direction of the slashes in the key value  to match the direction of the first three. Still no joy.

    I looked in C:\Program Files (x86)\The Anchorage\Beginner Word Addin and it appears that all of the necessary files are there.

    I'm am simply stumped with no idea what to try next. I've probably made a simple error somewhere along the way and jus don't know where to look.

    Thanks.


    Greg Maxey Please visit my website at: http://gregmaxey.mvps.org/word_tips.htm

    Friday, November 21, 2014 10:50 PM
  • Hi Greg,

    Make sure that you did all the steps described in the Deploying an Office Solution by Using Windows Installer article.

    • Marked as answer by Greg Maxey Saturday, November 22, 2014 1:16 PM
    Saturday, November 22, 2014 9:50 AM
  • Hi Eugene,

    I had followed all of the steps except the one about using Notepad to create the new redistributable.  When I had initially clicked on that item in the list it said that a newer version was available from InstallShield so I downloaded it and skipped that step.  I went back followed the steps in the article verbatim (I thought).

    Still no joy.

    To make a long and frustrating story short, I finally realized that I had used a European version of "behavior" in my registry key LoadBehavior.  I had created a key named "LoadBehaviour" by mistake.  After fixing that everything worked fine.

    I have loads and loads to learn, but at least I've managed to take the first small step.  Thanks for your interest and your help.

    I'd like to ask a minor related question. I have a few other third party Word Addins installed (e.g, PDFMaker.OfficeAddin).  I see their registry keys and notice the keys are similar except they don't have the "Manifest" key.  Why is that?  What is unique about the installation that I've created that requires the Manifest key?

       


    Greg Maxey Please visit my website at: http://gregmaxey.mvps.org/word_tips.htm

    Saturday, November 22, 2014 1:25 PM