none
Suitebar not Showing for Anonymous Users RRS feed

  • Question

  • SharePoint 2013 Team Site with Custom Masterpage.

    I have a subsite that is anonymous, and it works great. That is until I need a user to be able to login. 

    The suitebar is not available for anonymous users. As a matter of fact when I go to the site I have to hit refresh a couple of times to get the suitebar to come up. 

    This is not good for managers as they need to able to submit blog posts, but are not willing to hit the refresh button 3-5 times hoping they will be logged in.

    Thank you for any assistance.

    Thursday, February 16, 2017 6:43 PM

Answers

  • Hi,

    Please check whether it have a SecurityTrimming control wrapping the suite bar or not.

    If the suitebar not have permission, as a workaround, we can copy the suite bar HTML and add it to your master page.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, February 17, 2017 7:23 AM
    Moderator

All replies

  • Hi,

    Please check whether it have a SecurityTrimming control wrapping the suite bar or not.

    If the suitebar not have permission, as a workaround, we can copy the suite bar HTML and add it to your master page.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, February 17, 2017 7:23 AM
    Moderator
  • This was in fact the case thank you! I can't believe I let that slip.

    I rebuilt my masterpage using seattle as a base, and compare my finished products to verify.

    thanks again.

    Thursday, February 23, 2017 9:24 PM