locked
BootStrap Template. RRS feed

  • Question

  • User1421620300 posted

    Recently i was going to try and use a template that i was interested in for my project! I wanted to use the template from bootstrap website but have come to find that my navigation links are not connecting for some reason! Could someone explain to me what is the general idea surrounding the syntax in this area of navigation. I know it may be something misleading but would like clarification. I want to have my links working because it is not clear to me why they wont connect to pages of the site. I have taken time to try to fix the problem but not clear yet on how to fix! Thanks, Markus 33

    _Booking View"
    <nav class="navbar navbar-expand-lg navbar-light bg-light">
    <a class="navbar-brand" href="#">Navbar</a>
    <button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbarNavDropdown" aria-controls="navbarNavDropdown" aria-expanded="false" aria-label="Toggle navigation">
    <span class="navbar-toggler-icon"></span>
    </button>
    <div class="collapse navbar-collapse" id="navbarNavDropdown">
    <ul class="navbar-nav">
    <li class="nav-item active">
    <a class="nav-link" href="index">Home </a>           //Links do not work!..
    </li>
    <li class="nav-item">
    <a class="nav-link" href="about">About</a>
    </li>
    <li class="nav-item">
    <a class="nav-link" href="contact">Contact</a>
    </li>
    <li class="nav-item">
    <a class="nav-link" href="booking">Booking</a>
    </li>
    <li class="nav-item dropdown">
    <a class="nav-link dropdown-toggle" href="#" id="navbarDropdownMenuLink" role="button" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false">
    Dropdown link
    </a>
    <div class="dropdown-menu" aria-labelledby="navbarDropdownMenuLink">
    <a class="dropdown-item" href="#">Action</a>
    <a class="dropdown-item" href="#">Another action</a>
    <a class="dropdown-item" href="#">Something else here</a>
    </div>
    </li>
    </ul>
    </div>
    </nav>
    <link rel="stylesheet" href="https://stackpath.bootstrapcdn.com/bootstrap/4.1.3/css/bootstrap.min.css" integrity="sha384-MCw98/SFnGE8fJT3GXwEOngsV7Zt27NXFoaoApmYm81iuXoPkFOJwJ8ERdknLPMO" crossorigin="anonymous">

    Monday, October 8, 2018 3:45 PM

Answers

  • User1421620300 posted

    The issue has been corrected. I was not using my Main html elements inside of the page, html and body start end tags!..Thanks Guys! Markus33

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, October 8, 2018 5:32 PM