none
Turn off audio device control RRS feed

  • Question

  • Hello - with expression encoder 4, is there a way to turn off the audio device control, so the deck does not start when starting the encoder?  the wm9 encoder had the ability to toggle between the device control and no device control, but i am not finding that option with EE4.  thanks.
    Wednesday, April 6, 2011 7:35 PM

All replies

  • I don't believe I understand the question. What type of device are you looking to control (make and model).  When you start Expression Encoder one of your devices takes the action of starting automatically?
    Friday, April 8, 2011 4:17 PM
  • hello again -

    i misstated my earlier question.  can you turn off the auto device control?

    basically, i am capturing via firewire from various dv decks.  (such as a Sony GV-D900 MiniDV as well as various JVC MiniDV decks).  when i start the encoder it automatically starts playing the tape in the dv deck.  with WM9 encoder you could turn off the device control. with EE4, i see where you can bring up the device control when clicking the configure button next to the audio device, i just dont see where i can disable the device control.

    thanks.

    Tuesday, April 12, 2011 2:05 AM
  • We activate the transport controls for any device who's driver exposes the IAMExtTransport. We do not off a means by which, in the UI, you can tell the Expression Encoder to ignore that interface.

    Why the device starts playing when you start the Encoder sounds like a bug to me and I am chatting with my dev about this behavior. I expect it's when you create a Live device and not actually start Expression Encoder that the device's transport goes into Play mode correct?

    Tuesday, April 12, 2011 1:59 PM
  • when i hit 'start" on the expression encoder, it starts to play the tape in the dv deck.  i then can hit the stop button on the mini dv deck and start to record to my tape.  i can work around it, i am just switching from WM9 to EE4 and with WM9, you had the option of turning off the device control, so i didnt know if there was a similar option here, sounds like there is not.  thanks for the assistance.

    another specific deck this occurred on was a JVC 1394 DV AV/C Tape Recorder/Player

    Tuesday, April 12, 2011 4:01 PM
  • Got it.  You are correct, if the selected LiveSource does expose IAMExtTransport and is the cued device when you click Start, we do send the Play command to the device. One fo the reasons why this is done is, the way the pipeline is written, we demand A/V frames from the cued device at the start of the encoding process. I havent read the Media Encoder source but I suspect their pipeline will substitute blank frames if the cued device fails to send frames.

    I am adding a feature bug to our bug base for the product team's consideration affording the user the ability to override the default behavior and not auto-send Start / Stop commands to the device on the start of the encoding session.

    I have to apologize but hitting the stop control, as inconvenient as that is, is the only workaround at the moment.

    Tuesday, April 12, 2011 6:12 PM
  • Thanks for the assistance and info.

    I do have another question, I am capturing via firewire, from a camera or various mini dv decks.  I am having a problem with the audio and video being out of sync by a few frames.  i am using a Lenovo T410 Laptop to encode, i have tested this on 3 computers all with the same issue.  I have gone back and tested this with WM9 encoder and i do not have any issues with the audio and video being out of sync.  any advice on what i can do to correct this with EE4?

    Thanks.

    Wednesday, April 13, 2011 8:40 PM
  • Is the A/V synchronization flaw cumulative or do you experience a constant difference between the audio and video? Also I didn't catch whether or not the audio lags video or vice versa.
    Tuesday, April 26, 2011 7:37 PM